summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2019-08-28 00:51:00 +0100
committergrufo2019-08-28 00:51:00 +0100
commit91210c8ae8991e3f84d087981933f2028b89e862 (patch)
tree66882689cb309400b67771d7fff5ae61ed83cf18
downloadaur-91210c8ae8991e3f84d087981933f2028b89e862.tar.gz
First git commit (r1.81e72b5)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec1fdccc1a14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nautilus-bluetooth-git
+ pkgdesc = A simple Nautilus extension that adds a "Send via Bluetooth" entry to Nautilus' right-click menu
+ pkgver = r1.81e72b5
+ pkgrel = 1
+ url = https://github.com/madmurphy/nautilus-bluetooth
+ arch = any
+ license = GPL
+ makedepends = pkgconf
+ makedepends = intltool
+ depends = glib2
+ depends = libnautilus-extension
+ depends = gnome-bluetooth
+ provides = nautilus-bluetooth-git
+ conflicts = nautilus-bluetooth-git
+ source = git+https://github.com/madmurphy/nautilus-bluetooth.git
+ sha256sums = SKIP
+
+pkgname = nautilus-bluetooth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf053abcec3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: grufo <madmurphy333@gmail.com>
+
+pkgname='nautilus-bluetooth-git'
+_pkgname='nautilus-bluetooth'
+pkgver='r1.81e72b5'
+pkgrel=1
+pkgdesc="A simple Nautilus extension that adds a \"Send via Bluetooth\" entry to Nautilus' right-click menu"
+arch=('any')
+url="https://github.com/madmurphy/nautilus-bluetooth"
+license=('GPL')
+depends=('glib2' 'libnautilus-extension' 'gnome-bluetooth')
+makedepends=('pkgconf' 'intltool')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("git+https://github.com/madmurphy/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+
+ cd "${_pkgname}"
+ printf "'r%s.%s'" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare() {
+
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --noconfigure
+ ./configure --prefix=/usr
+
+}
+
+build() {
+
+ cd "${srcdir}/${_pkgname}"
+ make
+
+}
+
+
+check() {
+
+ cd "${srcdir}/${_pkgname}"
+ make check
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+}
+