summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-24 13:01:00 -0700
committeryochananmarqos2019-12-24 13:01:00 -0700
commit9be15681f51c3c92baaad21d9400f379bb6b3e1b (patch)
tree126a3ef7f49e8fbb768f191145a1eebb059af19c
parentb8fd651371ce0b92542085b66779b8969cfb17bb (diff)
downloadaur-9be15681f51c3c92baaad21d9400f379bb6b3e1b.tar.gz
disable post_install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43c21facb4cf..29ee88ba4d84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nautilus-ext-git-git
pkgdesc = Nautilus extension to add important information about the current git directory
pkgver = 1.3.r16.g5389549
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bilelmoussaoui/nautilus-git
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 45e7c6b9e713..ddce82cb1656 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=nautilus-ext-git-git
pkgver=1.3.r16.g5389549
-pkgrel=1
+pkgrel=2
pkgdesc="Nautilus extension to add important information about the current git directory"
arch=('i686' 'x86_64')
url="https://github.com/bilelmoussaoui/nautilus-git"
@@ -13,6 +13,13 @@ conflicts=("${pkgname%-git}" 'nautilus-git=1.3')
source=("${pkgname%-git}::git+https://github.com/bilelmoussaoui/nautilus-git")
sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Disable post_install, not available in meson-options
+ sed -i '37,38d' meson.build
+}
+
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
@@ -20,7 +27,7 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- arch-meson builddir -Dpost_install=false -Dfile_manager=nautilus
+ arch-meson builddir -Dfile_manager=nautilus
ninja -C builddir
}