summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-17 16:53:09 -0600
committerMark Wagie2021-06-17 16:53:09 -0600
commit9cfa9ee4f25871a22bd8c68c0072c9e7a554fd7e (patch)
treef18f98b9b0e5264e22623cb81891288f71e46518
parent57dc8bb2d2e9fbcb9a9ef9699d5a3dc74226544c (diff)
downloadaur-9cfa9ee4f25871a22bd8c68c0072c9e7a554fd7e.tar.gz
PKGBUILD adjustments
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85d311fa9188..ea9bea2b5af8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,11 @@ conflicts=("${pkgname%-git}"
source=("${pkgname%-git}::git+https://github.com/bilelmoussaoui/nautilus-git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "$srcdir/${pkgname%-git}"
@@ -22,11 +27,6 @@ prepare() {
sed -i '37,38d' meson.build
}
-pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
arch-meson "${pkgname%-git}" build -Dfile_manager=nautilus
meson compile -C build