summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthebitstick2020-04-17 02:04:20 -0500
committerthebitstick2020-04-17 02:04:20 -0500
commitb6e398c810e182104f459017a4fb6e5b209bcf7b (patch)
treeaa96c25e378e90b4ed7733abdd3b70ee8be49abd
downloadaur-b6e398c810e182104f459017a4fb6e5b209bcf7b.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a51c8eb4ad2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nautilus-gnome-disks-git
+ pkgdesc = Allows you to restore/write a disk image to storage devices using GNOME Disks from Nautilus
+ pkgver = r2.fc84c48
+ pkgrel = 1
+ url = https://github.com/thebitstick/nautilus-gnome-disks
+ arch = any
+ license = GPL3
+ depends = python-nautilus
+ depends = gnome-disk-utility
+ provides = nautilus-gnome-disks
+ conflicts = nautilus-gnome-disks
+ source = git+https://github.com/thebitstick/nautilus-gnome-disks
+ sha512sums = SKIP
+
+pkgname = nautilus-gnome-disks-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..678aa447c89f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: TheBitStick <thebitstick@librem.one> <the@bitstick.rip>
+pkgname=nautilus-gnome-disks-git
+_pkgname=nautilus-gnome-disks
+pkgver=r2.fc84c48
+pkgrel=1
+pkgdesc="Allows you to restore/write a disk image to storage devices using GNOME Disks from Nautilus"
+arch=('any')
+url="https://github.com/thebitstick/nautilus-gnome-disks"
+license=('GPL3')
+depends=('python-nautilus' 'gnome-disk-utility')
+provides=('nautilus-gnome-disks')
+conflicts=('nautilus-gnome-disks')
+source=('git+https://github.com/thebitstick/nautilus-gnome-disks')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install --mode=644 -D -t "$pkgdir/usr/share/nautilus-python/extensions" "${_pkgname}/nautilus-gnome-disks.py"
+}