summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2021-04-25 02:02:50 +0200
committergrufo2021-04-25 02:02:50 +0200
commit2d82c53f78244bbe972e3da9facf072fc3d16a9d (patch)
tree231f07da9a81161959c0f2287d8f5affa2433876
parentad2bffb4bb217d2b69e93147995e050003a11204 (diff)
downloadaur-2d82c53f78244bbe972e3da9facf072fc3d16a9d.tar.gz
New implementation of the extension written in C
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD49
-rw-r--r--nautilus-hide.install6
3 files changed, 48 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61cf392adc09..880612438980 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = nautilus-hide
- pkgdesc = Extension for Nautilus to hide files without renaming them
- pkgver = 0.2.1
+ pkgdesc = A simple Nautilus extension that adds "Hide" and "Unhide" to Nautilus right-click menu
+ pkgver = 0.1.0
pkgrel = 1
- url = https://github.com/brunonova/nautilus-hide
+ url = https://gitlab.gnome.org/madmurphy/nautilus-hide
install = nautilus-hide.install
- arch = any
- license = GPL3
- makedepends = cmake>=2.6
- makedepends = gettext
- depends = nautilus
- depends = python-nautilus
- depends = xdotool
- source = https://github.com/brunonova/nautilus-hide/releases/download/v0.2.1/nautilus-hide_0.2.1.tar.xz
- md5sums = 7eea2effd69b779f8caddb480352fb68
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = glib2
+ depends = libnautilus-extension
+ conflicts = nautilus-hide-git
+ conflicts = nautilus-hide-bin
+ source = https://gitlab.gnome.org/madmurphy/nautilus-hide/-/archive/0.1.0/nautilus-hide-0.1.0.tar.gz
+ sha256sums = 5accaef09428f86cc8f862330b830f664d890690386e677d91ce0600dd0a464a
pkgname = nautilus-hide
diff --git a/PKGBUILD b/PKGBUILD
index 269e405835ca..d30e79d27d57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
-# Maintainer: Bruno Nova <brunomb.nova@gmail.com>
-pkgname=nautilus-hide
-pkgver=0.2.1
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+
+pkgname='nautilus-hide'
+pkgver='0.1.0'
pkgrel=1
-pkgdesc="Extension for Nautilus to hide files without renaming them"
-arch=('any')
-url="https://github.com/brunonova/$pkgname"
-license=('GPL3')
-depends=('nautilus' 'python-nautilus' 'xdotool')
-makedepends=('cmake>=2.6' 'gettext')
-install="$pkgname.install"
-source=("https://github.com/brunonova/$pkgname/releases/download/v$pkgver/${pkgname}_$pkgver.tar.xz")
-md5sums=('7eea2effd69b779f8caddb480352fb68')
+pkgdesc='A simple Nautilus extension that adds "Hide" and "Unhide" to Nautilus right-click menu'
+arch=('i686' 'x86_64')
+url='https://gitlab.gnome.org/madmurphy/nautilus-hide'
+license=('GPL')
+depends=('glib2' 'libnautilus-extension')
+makedepends=('intltool')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
+source=("https://gitlab.gnome.org/madmurphy/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+install="${pkgname}.install"
+sha256sums=('5accaef09428f86cc8f862330b830f664d890690386e677d91ce0600dd0a464a')
+
+prepare() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./bootstrap --noconfigure
+
+}
build() {
- cd "$srcdir"
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
make
+
}
package() {
- cd "$srcdir"
- make DESTDIR="$pkgdir" install
- install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm644 "NEWS" "$pkgdir/usr/share/doc/$pkgname/NEWS"
- install -Dm644 "AUTHORS" "$pkgdir/usr/share/doc/$pkgname/AUTHORS"
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
}
+
diff --git a/nautilus-hide.install b/nautilus-hide.install
index d73966f2f3ce..d3bb1f6c5d4f 100644
--- a/nautilus-hide.install
+++ b/nautilus-hide.install
@@ -1,3 +1,7 @@
post_install() {
- echo 'Nautilus, if running, must be restarted for this extension to work (execute "nautilus -q").'
+ echo
+ echo 'After installing this package don'\''t forget to restart Nautilus, with'
+ echo
+ echo ' nautilus -q'
+ echo
}