summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2020-10-08 11:38:46 +0100
committergrufo2020-10-08 11:38:46 +0100
commit2f9d6b540776eb23fb64bf6b2fcda4d86c07ba30 (patch)
tree5f4aa4d819cf5c60f9e53b9bec4c12120799e0e6
downloadaur-2f9d6b540776eb23fb64bf6b2fcda4d86c07ba30.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09ddc10fdc09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nautilus-launch
+ pkgdesc = A simple Nautilus extension that allows to run executables and launchers via right-click menu
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/madmurphy/nautilus-launch
+ arch = any
+ license = GPL
+ makedepends = pkgconf
+ makedepends = intltool
+ depends = glib2
+ depends = libnautilus-extension
+ conflicts = nautilus-launch-git
+ conflicts = nautilus-launch-bin
+ source = https://github.com/madmurphy/nautilus-launch/releases/download/0.1.0/nautilus-launch-0.1.0-with-configure.tar.gz
+ sha256sums = 73a5b55956335d4d1eff0e8ef0ea46d473fc23f579b05f402a666478bcc985c9
+
+pkgname = nautilus-launch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e95f9861adf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+
+pkgname='nautilus-launch'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc='A simple Nautilus extension that allows to run executables and launchers via right-click menu'
+arch=('any')
+url='https://github.com/madmurphy/nautilus-launch'
+license=('GPL')
+depends=('glib2' 'libnautilus-extension')
+makedepends=('pkgconf' 'intltool')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
+source=("https://github.com/madmurphy/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-with-configure.tar.gz")
+sha256sums=('73a5b55956335d4d1eff0e8ef0ea46d473fc23f579b05f402a666478bcc985c9')
+
+build() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}-with-configure"
+ ./configure --prefix=/usr
+ make
+
+}
+
+package() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}-with-configure"
+ make DESTDIR="${pkgdir}" install
+
+}
+