summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Vaca Cintora2020-03-09 22:09:34 +0100
committerAlbert Vaca Cintora2020-03-09 22:09:34 +0100
commit2d301bd6ef9b8b6871693e7026c4a0ed1380b7a3 (patch)
treebc7b1fee3245ceb228a842cab841f4a81ecbfaf1
parent21dceeca2d63d202ebdf9f24ccbebbbaf397bc61 (diff)
downloadaur-2d301bd6ef9b8b6871693e7026c4a0ed1380b7a3.tar.gz
Fix build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a43a07c98d3..a5ce8ebe37fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,10 @@ pkgbase = nautilus-typeahead
pkgdesc = Default file manager for GNOME - Patched to bring back the 'typeahead find' feature
pkgver = 3.36.0
pkgrel = 1
- url = https://wiki.gnome.org/Apps/Nautilus
+ url = https://wiki.gnome.org/Apps/Files
arch = x86_64
license = GPL
makedepends = gobject-introspection
- makedepends = packagekit
makedepends = git
makedepends = gtk-doc
makedepends = meson
@@ -23,8 +22,10 @@ pkgbase = nautilus-typeahead
depends = tracker-miners
optdepends = nautilus-sendto: right click to send files
source = git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=e11034204be70a8535c8eff0010a2881991f17eb
+ source = git+https://gitlab.gnome.org/GNOME/libgd.git
source = nautilus-restore-typeahead.patch
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = d3e1a3df1042a412aa23d0a1710c490c117239cd4d9ae9bae2ee32e190c8c03f
pkgname = nautilus-typeahead
diff --git a/PKGBUILD b/PKGBUILD
index bd1ab2eea189..0d0d00293445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,24 +10,26 @@ packager="Albert Vaca Cintora <albertvaka@gmail.com>"
pkgver=3.36.0
pkgrel=1
pkgdesc="Default file manager for GNOME - Patched to bring back the 'typeahead find' feature"
-url="https://wiki.gnome.org/Apps/Nautilus"
+url="https://wiki.gnome.org/Apps/Files"
arch=(x86_64)
license=(GPL)
depends=(libgexiv2 gnome-desktop gvfs dconf tracker gnome-autoar
gst-plugins-base-libs tracker-miners)
-makedepends=(gobject-introspection packagekit git gtk-doc meson appstream-glib 'meson>=0.44.1' ninja)
+makedepends=(gobject-introspection git gtk-doc meson appstream-glib 'meson>=0.44.1' ninja)
optdepends=('nautilus-sendto: right click to send files')
_commit=e11034204be70a8535c8eff0010a2881991f17eb # tags/3.36.0^0
source=("git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=$_commit"
+ 'git+https://gitlab.gnome.org/GNOME/libgd.git'
nautilus-restore-typeahead.patch)
sha256sums=('SKIP'
+ 'SKIP'
'd3e1a3df1042a412aa23d0a1710c490c117239cd4d9ae9bae2ee32e190c8c03f')
prepare() {
cd $_pkgbase
git submodule init
- git submodule set-url subprojects/libgd "$srcdir/libgd"
+ git config submodule.libgd.url $srcdir/libgd
git submodule update
patch -p1 -i ../nautilus-restore-typeahead.patch
@@ -39,7 +41,9 @@ pkgver() {
}
build() {
- arch-meson $_pkgbase build -D docs=true
+ arch-meson $_pkgbase build \
+ -D docs=true \
+ -D packagekit=false
ninja -C build
}