summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Vaca2018-03-26 14:03:02 +0200
committerAlbert Vaca2018-03-26 14:03:22 +0200
commit3705d540b5f1f887c8414b2b4a6d8dce092c2e60 (patch)
tree314f83d7889178d5adf82da39f0d65837a9000ee
parent662e34f5884f7b2d01280270b9a7320091f2b944 (diff)
downloadaur-3705d540b5f1f887c8414b2b4a6d8dce092c2e60.tar.gz
Upgrade to 3.28.0.1
Also made nautilus-sendto optional
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
-rw-r--r--nautilus-restore-typeahead.patch62
-rw-r--r--nautilus.install14
5 files changed, 58 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4f17ffe0c91..37721f8783f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,47 +1,40 @@
# Generated by mksrcinfo v8
-# Sat Feb 24 11:46:06 UTC 2018
+# Mon Mar 26 12:03:12 UTC 2018
pkgbase = nautilus-typeahead
pkgdesc = Default file manager for GNOME - Patched to bring back the 'typeahead find' feature
- pkgver = 3.26.2
- pkgrel = 3
+ pkgver = 3.28.0.1
+ pkgrel = 1
url = https://wiki.gnome.org/Apps/Nautilus
arch = i686
arch = x86_64
license = GPL
- makedepends = intltool
makedepends = gobject-introspection
- makedepends = python
makedepends = packagekit
- makedepends = python2
- makedepends = gnome-common
makedepends = git
makedepends = gtk-doc
+ makedepends = appstream-glib
makedepends = meson>=0.44.1
makedepends = ninja
- depends = libexif
+ depends = libgexiv2
depends = gnome-desktop
- depends = exempi
depends = gvfs
depends = dconf
depends = tracker
- depends = nautilus-sendto
depends = gnome-autoar
+ optdepends = nautilus-sendto: right click to send files
options = !emptydirs
- source = git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=51637bc0960002b811e1c0c7be8671cf9a1cc5be
+ source = git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=9f28215927d023b54d88a25e026163e9e193bcf3
source = nautilus-restore-typeahead.patch
sha256sums = SKIP
- sha256sums = 17213656a016da2aaed14ca5c3cc9df30ad76ea59847b50dce4feb77619af274
+ sha256sums = d5eb01843d2758e74e25686f521f5fd72879e32595b494e9cabb8f8f1a2a87a5
pkgname = nautilus-typeahead
- install = nautilus.install
groups = gnome
- depends = libexif
+ depends = libgexiv2
depends = gnome-desktop
- depends = exempi
depends = gvfs
depends = dconf
depends = tracker
- depends = nautilus-sendto
depends = gnome-autoar
depends = libnautilus-extension-typeahead
provides = nautilus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..06477415788a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src/
+/pkg/
+/nautilus/
diff --git a/PKGBUILD b/PKGBUILD
index 34b047a6f26d..ab0cf9471d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,28 @@
_pkgbase=nautilus
pkgbase=nautilus-typeahead
pkgname=(nautilus-typeahead libnautilus-extension-typeahead)
-pkgver=3.26.2
-pkgrel=3
+pkgver=3.28.0.1
+pkgrel=1
pkgdesc="Default file manager for GNOME - Patched to bring back the 'typeahead find' feature"
url="https://wiki.gnome.org/Apps/Nautilus"
arch=(i686 x86_64)
license=(GPL)
-depends=(libexif gnome-desktop exempi gvfs dconf tracker nautilus-sendto gnome-autoar)
-makedepends=(intltool gobject-introspection python packagekit python2 gnome-common git gtk-doc 'meson>=0.44.1' ninja)
+depends=(libgexiv2 gnome-desktop gvfs dconf tracker gnome-autoar)
+makedepends=(gobject-introspection packagekit git gtk-doc appstream-glib 'meson>=0.44.1' ninja)
+optdepends=('nautilus-sendto: right click to send files')
options=(!emptydirs)
-_commit=51637bc0960002b811e1c0c7be8671cf9a1cc5be # tags/3.26.2
+_commit=9f28215927d023b54d88a25e026163e9e193bcf3 # tags/3.28.0.1
source=("git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=$_commit"
nautilus-restore-typeahead.patch)
sha256sums=('SKIP'
- '17213656a016da2aaed14ca5c3cc9df30ad76ea59847b50dce4feb77619af274')
+ 'd5eb01843d2758e74e25686f521f5fd72879e32595b494e9cabb8f8f1a2a87a5')
prepare() {
- mkdir -p build libne/usr/{lib,share}
- ls
cd $_pkgbase
git submodule init
git submodule update
- git cherry-pick -n d74e1a3d 9238456b bf86a803
-
patch -p1 -i ../nautilus-restore-typeahead.patch
}
@@ -40,30 +37,23 @@ pkgver() {
}
build() {
- cd build
- arch-meson ../nautilus \
- -Denable-exif=true \
- -Denable-xmp=true \
- -Denable-gtk-doc=true \
- -Denable-selinux=false
- ninja
+ arch-meson $_pkgbase build -D docs=true
+ ninja -C build
}
package_nautilus-typeahead() {
depends+=(libnautilus-extension-typeahead)
- install=nautilus.install
conflicts=(nautilus)
provides=(nautilus)
groups=(gnome)
- cd build
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" ninja -C build install
### Split libnautilus-extension
- cd ../libne
- mv "$pkgdir"/usr/include usr
- mv "$pkgdir"/usr/lib/{girepository-1.0,libnautilus-extension*,pkgconfig} usr/lib
- mv "$pkgdir"/usr/share/{gir-1.0,gtk-doc} usr/share
+ mkdir -p libne/{lib,share}
+ mv "$pkgdir"/usr/include libne
+ mv "$pkgdir"/usr/lib/{girepository-1.0,libnautilus-extension*,pkgconfig} libne/lib
+ mv "$pkgdir"/usr/share/{gir-1.0,gtk-doc} libne/share
}
package_libnautilus-extension-typeahead() {
@@ -72,5 +62,5 @@ package_libnautilus-extension-typeahead() {
provides=(libnautilus-extension)
depends=(gtk3)
- mv libne/usr "$pkgdir"
+ mv libne "$pkgdir/usr"
}
diff --git a/nautilus-restore-typeahead.patch b/nautilus-restore-typeahead.patch
index 9c1f4890acfb..7ed3e727ee61 100644
--- a/nautilus-restore-typeahead.patch
+++ b/nautilus-restore-typeahead.patch
@@ -21,13 +21,13 @@ index ce0b32c9d..a624e7551 100644
@@ -161,6 +161,9 @@ typedef enum
/* Recent files */
#define NAUTILUS_PREFERENCES_RECENT_FILES_ENABLED "remember-recent-files"
-
+
+/* Interactive search (typeahead) */
+#define NAUTILUS_PREFERENCES_ENABLE_INTERACTIVE_SEARCH "enable-interactive-search"
+
/* Move to trash shorcut changed dialog */
#define NAUTILUS_PREFERENCES_SHOW_MOVE_TO_TRASH_SHORTCUT_CHANGED_DIALOG "show-move-to-trash-shortcut-changed-dialog"
-
+
diff --git a/src/nautilus-list-view.c b/src/nautilus-list-view.c
index 759e3b158..fbfbd6fee 100644
--- a/src/nautilus-list-view.c
@@ -36,28 +36,28 @@ index 759e3b158..fbfbd6fee 100644
GList *node;
GList *iters, *l;
NautilusFile *file;
-+ GtkTreePath *path = NULL;
-
++ GtkTreePath *path2 = NULL;
+
list_view = NAUTILUS_LIST_VIEW (view);
tree_selection = gtk_tree_view_get_selection (list_view->details->tree_view);
@@ -2778,10 +2779,22 @@ nautilus_list_view_set_selection (NautilusFilesView *view,
{
gtk_tree_selection_select_iter (tree_selection,
(GtkTreeIter *) l->data);
-+ if (!path)
-+ path = gtk_tree_model_get_path (GTK_TREE_MODEL (list_view->details->model), (GtkTreeIter *) l->data);
++ if (!path2)
++ path2 = gtk_tree_model_get_path (GTK_TREE_MODEL (list_view->details->model), (GtkTreeIter *) l->data);
}
+
g_list_free_full (iters, g_free);
}
-
-+ if (path) {
+
++ if (path2) {
+ gtk_tree_view_set_cursor_on_cell (list_view->details->tree_view,
-+ path,
++ path2,
+ list_view->details->file_name_column,
+ GTK_CELL_RENDERER (list_view->details->file_name_cell),
+ TRUE);
-+ gtk_tree_path_free (path);
++ gtk_tree_path_free (path2);
+ }
+
g_signal_handlers_unblock_by_func (tree_selection, list_selection_changed_callback, view);
@@ -79,10 +79,10 @@ index 04989fa95..fc15f0986 100644
+++ b/src/nautilus-list-view.h
@@ -39,5 +39,6 @@ struct _NautilusListView
};
-
+
NautilusFilesView * nautilus_list_view_new (NautilusWindowSlot *slot);
+GtkTreeView * nautilus_list_view_get_tree_view (NautilusListView *list_view);
-
+
#endif /* NAUTILUS_LIST_VIEW_H */
diff --git a/src/nautilus-window-slot.c b/src/nautilus-window-slot.c
index d364115a9..054edba8a 100644
@@ -104,12 +104,12 @@ index d364115a9..054edba8a 100644
+ guint isearch_timeout_id;
+ gulong isearch_configure_event_id;
} NautilusWindowSlotPrivate;
-
+
G_DEFINE_TYPE_WITH_PRIVATE (NautilusWindowSlot, nautilus_window_slot, GTK_TYPE_BOX);
@@ -208,6 +219,98 @@ nautilus_window_slot_get_restore_tab_data (NautilusWindowSlot *self)
return data;
}
-
+
+
+/* Interactive search */
+static void isearch_ensure (NautilusWindowSlot *slot);
@@ -208,7 +208,7 @@ index d364115a9..054edba8a 100644
@@ -637,21 +740,86 @@ nautilus_window_slot_handle_event (NautilusWindowSlot *self,
}
}
-
+
- /* If the action is not enabled, don't try to handle search */
- if (g_action_get_enabled (action))
- {
@@ -265,7 +265,7 @@ index d364115a9..054edba8a 100644
+ gtk_widget_grab_focus (GTK_WIDGET (self));
+ return TRUE;
+ }
-
+
- if (retval)
- {
- nautilus_window_slot_set_search_visible (self, TRUE);
@@ -285,10 +285,10 @@ index d364115a9..054edba8a 100644
+ nautilus_window_slot_set_search_visible (self, TRUE);
+ }
}
-
+
return retval;
}
-
+
+/* static gboolean
+configure_event_cb (GtkWidget *widget,
+ GdkEventConfigure *event,
@@ -306,11 +306,11 @@ index d364115a9..054edba8a 100644
{
NautilusWindow *window;
+ NautilusWindowSlotPrivate *priv;
-
+
+ priv = nautilus_window_slot_get_instance_private (self);
window = nautilus_window_slot_get_window (self);
g_assert (self == nautilus_window_get_active_slot (window));
-
+
+ isearch_hide (self, NULL);
+ if (priv->isearch_configure_event_id != 0) {
+ g_signal_handler_disconnect (GTK_WIDGET (priv->window),
@@ -320,11 +320,11 @@ index d364115a9..054edba8a 100644
+
gtk_widget_insert_action_group (GTK_WIDGET (window), "slot", NULL);
}
-
+
@@ -976,9 +1153,30 @@ nautilus_window_slot_init (NautilusWindowSlot *self)
nautilus_application_set_accelerator (app, "slot.files-view-mode(uint32 0)", "<control>2");
nautilus_application_set_accelerator (app, "slot.search-visible", "<control>f");
-
+
+ priv->isearch_enable = g_settings_get_boolean (nautilus_preferences,
+ NAUTILUS_PREFERENCES_ENABLE_INTERACTIVE_SEARCH);
+
@@ -335,7 +335,7 @@ index d364115a9..054edba8a 100644
+
priv->view_mode_before_search = NAUTILUS_VIEW_INVALID_ID;
}
-
+
+static void
+nautilus_window_slot_finalize (GObject *object)
+{
@@ -351,13 +351,13 @@ index d364115a9..054edba8a 100644
+
#define DEBUG_FLAG NAUTILUS_DEBUG_WINDOW
#include "nautilus-debug.h"
-
+
@@ -2782,6 +2980,7 @@ nautilus_window_slot_dispose (GObject *object)
-
+
self = NAUTILUS_WINDOW_SLOT (object);
priv = nautilus_window_slot_get_instance_private (self);
+ isearch_dispose (self);
-
+
nautilus_window_slot_clear_forward_list (self);
nautilus_window_slot_clear_back_list (self);
@@ -2873,6 +3072,7 @@ nautilus_window_slot_class_init (NautilusWindowSlotClass *klass)
@@ -365,11 +365,11 @@ index d364115a9..054edba8a 100644
oclass->set_property = nautilus_window_slot_set_property;
oclass->get_property = nautilus_window_slot_get_property;
+ oclass->finalize = nautilus_window_slot_finalize;
-
+
widget_class->grab_focus = nautilus_window_slot_grab_focus;
-
+
@@ -3295,3 +3495,792 @@ nautilus_window_slot_get_loading (NautilusWindowSlot *self)
-
+
return priv->loading;
}
+
@@ -515,7 +515,7 @@ index d364115a9..054edba8a 100644
+ {
+ NautilusCanvasContainer *cc = nautilus_canvas_view_get_canvas_container (
+ NAUTILUS_CANVAS_VIEW (priv->content_view));
-+ gboolean retval;
++ gboolean retval = FALSE;
+
+ if (event->window == gtk_layout_get_bin_window (GTK_LAYOUT (cc)))
+ g_signal_emit_by_name (GTK_WIDGET (cc), "button-press-event", event,
@@ -525,7 +525,7 @@ index d364115a9..054edba8a 100644
+ }
+ else if (NAUTILUS_IS_LIST_VIEW (priv->content_view))
+ {
-+ gboolean retval;
++ gboolean retval = FALSE;
+ // NautilusListView *lv = NAUTILUS_LIST_VIEW (priv->content_view);
+ GtkTreeView *tv =
+ nautilus_list_view_get_tree_view (NAUTILUS_LIST_VIEW (priv->content_view));
diff --git a/nautilus.install b/nautilus.install
deleted file mode 100644
index 082126d24bce..000000000000
--- a/nautilus.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
- update-mime-database /usr/share/mime > /dev/null
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}