summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Vaca Cintora2022-11-08 22:29:50 +0100
committerAlbert Vaca Cintora2022-11-08 22:29:50 +0100
commit634dc0454389f3803c06d8968bb1c8f9e52d57a1 (patch)
tree1e5f557e601b3ae30fdf8362725fe379945a84aa
parentc3a55cc34513a5b3864d74eeefcb61c1a4222dd9 (diff)
downloadaur-634dc0454389f3803c06d8968bb1c8f9e52d57a1.tar.gz
Fix build against gnome 43
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--nautilus-thumbnails-compat.patch45
3 files changed, 57 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fe7a2126889..378413643aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nautilus-typeahead
pkgdesc = Default file manager for GNOME - Patched to bring back the 'typeahead find' feature
pkgver = 42.2
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Files
arch = x86_64
license = GPL
@@ -24,12 +24,15 @@ pkgbase = nautilus-typeahead
depends = libhandy
depends = libportal-gtk3
optdepends = nautilus-sendto: right click to send files
+ optdepends = python-nautilus-1: to use extensions in python
source = git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=6a9ee939f5419262d7d0ce720572805f5f64569b
source = git+https://gitlab.gnome.org/GNOME/libgd.git
source = nautilus-restore-typeahead.patch
+ source = nautilus-thumbnails-compat.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 52e9d930a01a40a8dde0136ded7b5c8283eb7d72f5a7bfb0790b0bbdbc2109bf
+ sha256sums = d316704f8ecc89734342e962e2632baacbd65609677e25366bceef3c0b9df62c
pkgname = nautilus-typeahead
groups = gnome
diff --git a/PKGBUILD b/PKGBUILD
index 63de2344981a..d1c7052d1402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgbase=nautilus-typeahead
pkgname=(nautilus-typeahead libnautilus-extension-typeahead)
packager="Albert Vaca Cintora <albertvaka@gmail.com>"
pkgver=42.2
-pkgrel=1
+pkgrel=2
pkgdesc="Default file manager for GNOME - Patched to bring back the 'typeahead find' feature"
url="https://wiki.gnome.org/Apps/Files"
arch=(x86_64)
@@ -16,15 +16,18 @@ license=(GPL)
depends=(libgexiv2 gnome-desktop gvfs dconf tracker3 tracker3-miners
gnome-autoar gst-plugins-base-libs libhandy libportal-gtk3)
makedepends=(gobject-introspection git gtk-doc meson appstream-glib 'meson>=0.44.1' ninja)
-optdepends=('nautilus-sendto: right click to send files')
+optdepends=('nautilus-sendto: right click to send files'
+ 'python-nautilus-1: to use extensions in python')
checkdepends=(python-gobject)
_commit=6a9ee939f5419262d7d0ce720572805f5f64569b
source=("git+https://gitlab.gnome.org/GNOME/nautilus.git#commit=$_commit"
'git+https://gitlab.gnome.org/GNOME/libgd.git'
- nautilus-restore-typeahead.patch)
+ nautilus-restore-typeahead.patch
+ nautilus-thumbnails-compat.patch)
sha256sums=('SKIP'
'SKIP'
- '52e9d930a01a40a8dde0136ded7b5c8283eb7d72f5a7bfb0790b0bbdbc2109bf')
+ '52e9d930a01a40a8dde0136ded7b5c8283eb7d72f5a7bfb0790b0bbdbc2109bf'
+ 'd316704f8ecc89734342e962e2632baacbd65609677e25366bceef3c0b9df62c')
pkgver() {
cd "$_pkgbase"
@@ -39,6 +42,7 @@ prepare() {
git submodule update
patch -p1 -i ../nautilus-restore-typeahead.patch
+ patch -p1 -i ../nautilus-thumbnails-compat.patch
}
diff --git a/nautilus-thumbnails-compat.patch b/nautilus-thumbnails-compat.patch
new file mode 100644
index 000000000000..10631f36e992
--- /dev/null
+++ b/nautilus-thumbnails-compat.patch
@@ -0,0 +1,45 @@
+diff --git a/src/nautilus-thumbnails.c b/src/nautilus-thumbnails.c
+index 8b532f260..dc607d019 100644
+--- a/src/nautilus-thumbnails.c
++++ b/src/nautilus-thumbnails.c
+@@ -447,6 +447,7 @@ thumbnail_thread_func (GTask *task,
+ time_t current_orig_mtime = 0;
+ time_t current_time;
+ GList *node;
++ GError *error = NULL;
+
+ thumbnail_factory = get_thumbnail_factory ();
+
+@@ -529,7 +530,10 @@ thumbnail_thread_func (GTask *task,
+
+ pixbuf = gnome_desktop_thumbnail_factory_generate_thumbnail (thumbnail_factory,
+ info->image_uri,
+- info->mime_type);
++ info->mime_type,
++ NULL,
++ &error
++ );
+
+ if (pixbuf)
+ {
+@@ -539,7 +543,9 @@ thumbnail_thread_func (GTask *task,
+ gnome_desktop_thumbnail_factory_save_thumbnail (thumbnail_factory,
+ pixbuf,
+ info->image_uri,
+- current_orig_mtime);
++ current_orig_mtime,
++ NULL,
++ &error);
+ g_object_unref (pixbuf);
+ }
+ else
+@@ -549,7 +555,8 @@ thumbnail_thread_func (GTask *task,
+
+ gnome_desktop_thumbnail_factory_create_failed_thumbnail (thumbnail_factory,
+ info->image_uri,
+- current_orig_mtime);
++ current_orig_mtime,
++ NULL, NULL);
+ }
+ /* We need to call nautilus_file_changed(), but I don't think that is
+ * thread safe. So add an idle handler and do it from the main loop. */