summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Hernández2015-09-11 16:39:49 -0500
committerIan Hernández2015-09-11 16:39:49 -0500
commit756258690eb788e03b2b84bcd4232b017e55d729 (patch)
tree8aa8591c6c659af4cab9259ab1564b14c09988ee
parentc613a08a5464237e0837a999076cb65607ff174a (diff)
downloadaur-756258690eb788e03b2b84bcd4232b017e55d729.tar.gz
PKGBUILD corrected
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c6a2031c56f..4e108e158cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
# Maintainer: Ian Hernández <ihernandezs@openmailbox.org>
-pkgbase=nautilus
+_pkgbase=nautilus
pkgname=nautilus-typeahead
+pkgbase=$pkgname
pkgver=3.16.2
pkgrel=1
pkgdesc="GNOME file manager - Patched to bring back the 'typeahead find' feature"
@@ -14,17 +15,17 @@ depends=(libexif gnome-desktop exempi gvfs desktop-file-utils dconf
makedepends=(intltool gobject-introspection python python2 packagekit)
url="http://www.gnome.org"
options=('!emptydirs')
-source=(http://download.gnome.org/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz nautilus-restore-typeahead.patch)
+source=(http://download.gnome.org/sources/$_pkgbase/${pkgver:0:4}/$_pkgbase-$pkgver.tar.xz nautilus-restore-typeahead.patch)
sha256sums=('3e7ecdda3a47b6ad03098270940aa506782866fa3602d91e711d99f96741478f' '42baee0cd2a93bf8433da3c611a8acd30df39f15d89179dbbdbe65d08d0b3515')
prepare() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
patch -p1 -i ../nautilus-restore-typeahead.patch
autoreconf -f -i
}
build() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --disable-static \
--libexecdir=/usr/lib/nautilus \
@@ -36,10 +37,10 @@ build() {
package_nautilus-typeahead() {
depends+=(libnautilus-extension)
install=nautilus.install
- conflicts=$pkgbase
- provides=$pkgbase
+ conflicts=$_pkgbase
+ provides=$_pkgbase
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
make DESTDIR="$pkgdir" install
### Split libnautilus-extension