summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Hernández2015-09-10 20:23:07 -0500
committerIan Hernández2015-09-10 20:23:07 -0500
commite03fed4ef971480e050d00775e5dc36d8723ccc1 (patch)
tree5039cb569f17c31c0d6848ca18bbd80b7b9ee1b8
downloadaur-e03fed4ef971480e050d00775e5dc36d8723ccc1.tar.gz
Initial commit - nautilus-typeahead 3.16.2-1
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD60
-rw-r--r--nautilus-restore-typeahead.patch12
-rw-r--r--nautilus.install14
4 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9373bc103dad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = nautilus
+ pkgdesc = GNOME file manager
+ pkgver = 3.16.2
+ pkgrel = 1
+ url = http://www.gnome.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = gobject-introspection
+ makedepends = python
+ makedepends = python2
+ makedepends = packagekit
+ depends = libexif
+ depends = gnome-desktop
+ depends = exempi
+ depends = gvfs
+ depends = desktop-file-utils
+ depends = dconf
+ depends = libtracker-sparql
+ depends = libnotify
+ depends = nautilus-sendto
+ provides = nautilus
+ conflicts = nautilus
+ options = !emptydirs
+ source = http://download.gnome.org/sources/nautilus/3.16/nautilus-3.16.2.tar.xz
+ source = nautilus-restore-typeahead.patch
+ sha256sums = 3e7ecdda3a47b6ad03098270940aa506782866fa3602d91e711d99f96741478f
+ sha256sums = 42baee0cd2a93bf8433da3c611a8acd30df39f15d89179dbbdbe65d08d0b3515
+
+pkgname = nautilus-typeahead
+ install = nautilus.install
+ groups = gnome
+ depends = libexif
+ depends = gnome-desktop
+ depends = exempi
+ depends = gvfs
+ depends = desktop-file-utils
+ depends = dconf
+ depends = libtracker-sparql
+ depends = libnotify
+ depends = nautilus-sendto
+ depends = libnautilus-extension
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ce60236d01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# $Id: PKGBUILD 239312 2015-05-13 21:24:40Z heftig $
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Ian Hernández <ihernandezs@openmailbox.org>
+
+pkgbase=nautilus
+pkgname=nautilus-typeahead
+pkgver=3.16.2
+pkgrel=1
+pkgdesc="GNOME file manager"
+arch=(i686 x86_64)
+license=(GPL)
+depends=(libexif gnome-desktop exempi gvfs desktop-file-utils dconf
+ libtracker-sparql libnotify nautilus-sendto)
+makedepends=(intltool gobject-introspection python python2 packagekit)
+url="http://www.gnome.org"
+options=('!emptydirs')
+source=(http://download.gnome.org/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz nautilus-restore-typeahead.patch)
+sha256sums=('3e7ecdda3a47b6ad03098270940aa506782866fa3602d91e711d99f96741478f' '42baee0cd2a93bf8433da3c611a8acd30df39f15d89179dbbdbe65d08d0b3515')
+conflicts=$pkgbase
+provides=$pkgbase
+
+prepare() {
+ cd $pkgbase-$pkgver
+ patch -p1 -i ../nautilus-restore-typeahead.patch
+ autoreconf -f -i
+}
+
+build() {
+ cd $pkgbase-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --libexecdir=/usr/lib/nautilus \
+ --disable-update-mimedb \
+ --disable-schemas-compile
+ make
+}
+
+package_nautilus-typeahead() {
+ depends+=(libnautilus-extension)
+ groups=(gnome)
+ install=nautilus.install
+
+ cd $pkgbase-$pkgver
+ make DESTDIR="$pkgdir" install
+
+### Split libnautilus-extension
+ cd ..
+ mkdir -p n-e/usr/{lib,share}
+ mv "$pkgdir"/usr/include n-e/usr
+ mv "$pkgdir"/usr/lib/{girepository-1.0,pkgconfig} n-e/usr/lib
+ mv "$pkgdir"/usr/lib/libnautilus-extension.so* n-e/usr/lib
+ mv "$pkgdir"/usr/share/{gir-1.0,gtk-doc} n-e/usr/share
+}
+
+# package_libnautilus-extension() {
+# pkgdesc="Library for extending the $pkgdesc"
+# depends=(gtk3)
+
+# mv n-e/* "$pkgdir"
+# }
diff --git a/nautilus-restore-typeahead.patch b/nautilus-restore-typeahead.patch
new file mode 100644
index 000000000000..119086bd2a16
--- /dev/null
+++ b/nautilus-restore-typeahead.patch
@@ -0,0 +1,12 @@
+diff -aur nautilus-3.16.2/src/nautilus-list-view.c nautilus-3.16.2.new/src/nautilus-list-view.c
+--- nautilus-3.16.2/src/nautilus-list-view.c 2015-05-13 12:24:43.000000000 -0500
++++ nautilus-3.16.2.new/src/nautilus-list-view.c 2015-09-10 18:54:11.942923502 -0500
+@@ -1923,7 +1923,7 @@
+ g_str_equal,
+ (GDestroyNotify) g_free,
+ NULL);
+- gtk_tree_view_set_enable_search (view->details->tree_view, FALSE);
++ gtk_tree_view_set_enable_search (view->details->tree_view, TRUE);
+
+ view->details->drag_dest =
+ nautilus_tree_view_drag_dest_new (view->details->tree_view);
diff --git a/nautilus.install b/nautilus.install
new file mode 100644
index 000000000000..082126d24bce
--- /dev/null
+++ b/nautilus.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-mime-database /usr/share/mime > /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}