summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author隠岐奈2017-12-26 13:52:07 -0600
committer隠岐奈2017-12-26 13:52:07 -0600
commitfd0409f5be763c19a02cc5e59c6ce003dcd78017 (patch)
treea31c14144f977f7acbfc6ccd0564a103d4a0c971
downloadaur-fd0409f5be763c19a02cc5e59c6ce003dcd78017.tar.gz
Initial upload
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD42
-rw-r--r--navcoin.desktop9
-rw-r--r--navcoind.service18
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52a7e8ad53c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = navcoin
+ pkgdesc = Privacy-oriented cryptocurrency and distributed computing platform
+ pkgver = 4.1.1
+ pkgrel = 1
+ url = https://navcoin.org/
+ arch = any
+ license = MIT
+ makedepends = miniupnpc
+ makedepends = db4.8
+ makedepends = qt5-base
+ makedepends = protobuf
+ makedepends = qrencode
+ makedepends = zeromq
+ depends = boost
+ depends = python
+ optdepends = miniupnpc: Firewall-jumping support
+ optdepends = db4.8: Wallet storage
+ optdepends = qt5-base: GUI toolkit
+ optdepends = protobuf: Data interchange format used for payment protocol
+ optdepends = qrencode: Generate QR codes
+ optdepends = zeromq: Generate ZMQ notifications
+ provides = navcoin
+ conflicts = navcoin-bin
+ conflicts = navcoin-git
+ source = https://github.com/NAVCoin/navcoin-core/releases/download/4.1.1/navcoin-4.1.1.tar.gz
+ source = navcoin.desktop
+ source = navcoind.service
+ md5sums = 35c8b696f09681f80943e7adb0ccab34
+ md5sums = 1885c0577f19f819aafc56c7ea52f00a
+ md5sums = c67b248610947e2fd11489923eed7fa0
+
+pkgname = navcoin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ce09a9ec8f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: 隠岐奈 <okinan@protonmail.com>
+pkgname='navcoin'
+pkgver='4.1.1'
+pkgrel='1'
+pkgdesc="Privacy-oriented cryptocurrency and distributed computing platform"
+arch=('any')
+url="https://navcoin.org/"
+license=('MIT')
+depends=('boost' 'python')
+makedepends=('miniupnpc' 'db4.8' 'qt5-base' 'protobuf' 'qrencode' 'zeromq')
+optdepends=('miniupnpc: Firewall-jumping support'
+ 'db4.8: Wallet storage'
+ 'qt5-base: GUI toolkit'
+ 'protobuf: Data interchange format used for payment protocol'
+ 'qrencode: Generate QR codes'
+ 'zeromq: Generate ZMQ notifications')
+provides=('navcoin')
+conflicts=('navcoin-bin' 'navcoin-git')
+source=("https://github.com/NAVCoin/navcoin-core/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "navcoin.desktop"
+ "navcoind.service")
+md5sums=('35c8b696f09681f80943e7adb0ccab34'
+ '1885c0577f19f819aafc56c7ea52f00a'
+ 'c67b248610947e2fd11489923eed7fa0')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ ./autogen.sh
+ ./configure --enable-upnp-default --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}/" install
+
+ install -Dm644 "${srcdir}/navcoind.service" "${pkgdir}/usr/lib/systemd/system/navcoind.service"
+ install -Dm644 "${srcdir}/navcoin.desktop" "${pkgdir}/usr/share/applications/navcoin.desktop"
+}
diff --git a/navcoin.desktop b/navcoin.desktop
new file mode 100644
index 000000000000..663bbd2cc4a3
--- /dev/null
+++ b/navcoin.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Nav Coin
+Comment=Privacy-oriented cryptocurrency and distributed computing platform
+TryExec=navcoin-qt
+Exec=navcoin-qt %U
+Icon=navcoin
+StartupNotify=true
+Terminal=false
+Type=Application
diff --git a/navcoind.service b/navcoind.service
new file mode 100644
index 000000000000..e7d0b58e88f2
--- /dev/null
+++ b/navcoind.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Nav Coin Daemon
+After=network.target
+
+[Service]
+User=navcoin
+Group=navcoin
+WorkingDirectory=~
+RuntimeDirectory=navcoin
+
+Type=forking
+PIDFile=/run/navcoin/navcoind.pid
+
+ExecStart=/usr/bin/navcoind --config-file /etc/navcoind.conf \
+ --detach --pidfile /run/navcoin/navcoind.pid
+
+[Install]
+WantedBy=multi-user.target