summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author隠岐奈2017-12-26 13:54:13 -0600
committer隠岐奈2017-12-26 13:54:13 -0600
commitbb3704b719a5d66fb877050dbdcdeb454a75a7ec (patch)
treec6d72d74a94f2425bf21e857367c3b93178f1c0b
downloadaur-bb3704b719a5d66fb877050dbdcdeb454a75a7ec.tar.gz
Initial upload
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD49
-rw-r--r--navcoin.desktop9
-rw-r--r--navcoind.service18
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d86bc9065d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = navcoin-git
+ pkgdesc = Privacy-oriented cryptocurrency and distributed computing platform - Git version
+ pkgver = r809.6f4be6f
+ pkgrel = 1
+ url = https://navcoin.org/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = miniupnpc
+ makedepends = db4.8
+ makedepends = qt5-base
+ makedepends = protobuf
+ makedepends = qrencode
+ makedepends = zeromq
+ depends = boost
+ depends = python
+ optdepends = miniupnpc: Firewall-jumping support
+ optdepends = db4.8: Wallet storage
+ optdepends = qt5-base: GUI toolkit
+ optdepends = protobuf: Data interchange format used for payment protocol
+ optdepends = qrencode: Generate QR codes
+ optdepends = zeromq: Generate ZMQ notifications
+ provides = navcoin-git
+ conflicts = navcoin
+ conflicts = navcoin-bin
+ source = git+https://github.com/NAVCoin/navcoin-core.git
+ source = navcoin.desktop
+ source = navcoind.service
+ md5sums = SKIP
+ md5sums = 1885c0577f19f819aafc56c7ea52f00a
+ md5sums = c67b248610947e2fd11489923eed7fa0
+
+pkgname = navcoin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..425fea239565
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: 隠岐奈 <okinan@protonmail.com>
+_basename='navcoin'
+pkgname='navcoin-git'
+pkgver='r809.6f4be6f'
+pkgrel='1'
+pkgdesc="Privacy-oriented cryptocurrency and distributed computing platform - Git version"
+arch=('any')
+url="https://navcoin.org/"
+license=('MIT')
+depends=('boost' 'python')
+makedepends=('git' 'miniupnpc' 'db4.8' 'qt5-base' 'protobuf' 'qrencode' 'zeromq')
+optdepends=('miniupnpc: Firewall-jumping support'
+ 'db4.8: Wallet storage'
+ 'qt5-base: GUI toolkit'
+ 'protobuf: Data interchange format used for payment protocol'
+ 'qrencode: Generate QR codes'
+ 'zeromq: Generate ZMQ notifications')
+provides=('navcoin-git')
+conflicts=('navcoin' 'navcoin-bin')
+source=("git+https://github.com/NAVCoin/navcoin-core.git"
+ "navcoin.desktop"
+ "navcoind.service")
+md5sums=('SKIP'
+ '1885c0577f19f819aafc56c7ea52f00a'
+ 'c67b248610947e2fd11489923eed7fa0')
+
+pkgver() {
+ cd "${_basename}-core"
+
+ printf "'r%s.%s'" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_basename}-core"
+
+ ./autogen.sh
+ ./configure --enable-upnp-default --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "${_basename}-core"
+
+ make DESTDIR="${pkgdir}/" install
+
+ install -Dm644 "${srcdir}/navcoind.service" "${pkgdir}/usr/lib/systemd/system/navcoind.service"
+ install -Dm644 "${srcdir}/navcoin.desktop" "${pkgdir}/usr/share/applications/navcoin.desktop"
+}
diff --git a/navcoin.desktop b/navcoin.desktop
new file mode 100644
index 000000000000..663bbd2cc4a3
--- /dev/null
+++ b/navcoin.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Nav Coin
+Comment=Privacy-oriented cryptocurrency and distributed computing platform
+TryExec=navcoin-qt
+Exec=navcoin-qt %U
+Icon=navcoin
+StartupNotify=true
+Terminal=false
+Type=Application
diff --git a/navcoind.service b/navcoind.service
new file mode 100644
index 000000000000..e7d0b58e88f2
--- /dev/null
+++ b/navcoind.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Nav Coin Daemon
+After=network.target
+
+[Service]
+User=navcoin
+Group=navcoin
+WorkingDirectory=~
+RuntimeDirectory=navcoin
+
+Type=forking
+PIDFile=/run/navcoin/navcoind.pid
+
+ExecStart=/usr/bin/navcoind --config-file /etc/navcoind.conf \
+ --detach --pidfile /run/navcoin/navcoind.pid
+
+[Install]
+WantedBy=multi-user.target