summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihaly Csonka2020-03-14 01:12:27 +0100
committerMihaly Csonka2020-03-14 01:12:27 +0100
commitf8c2126b2a08616689befe6ed6960e6727bfcd62 (patch)
tree6804c1a1ae067ecb4a9a1023e6bae2ddabe1c39f
parentef0a646c7fa5ef1c1a99434831022e6ef274919b (diff)
downloadaur-f8c2126b2a08616689befe6ed6960e6727bfcd62.tar.gz
Fix install message
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
-rw-r--r--navi.install3
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8450d68ea64a..f9fea5adc0ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = navi-git
pkgdesc = An interactive cheatsheet tool for the command-line.
pkgver = r238.8d0c82c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/denisidoro/navi
+ install = navi.install
arch = any
license = Apache 2.0
makedepends = git
@@ -13,8 +14,10 @@ pkgbase = navi-git
conflicts = navi
source = navi-git::git+https://github.com/denisidoro/navi
source = navi.sh
+ source = navi.install
md5sums = SKIP
md5sums = 43cf44f1cd5b9a7bb8f247735a59ba91
+ md5sums = 27308a8ca0e77387464dbd7f1e0bcdd4
pkgname = navi-git
diff --git a/PKGBUILD b/PKGBUILD
index 9224b0e0e2c1..26201f433e60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kibouo <csonka.mihaly@hotmail.com>
pkgname=navi-git
pkgver=r238.8d0c82c
-pkgrel=1
+pkgrel=2
pkgdesc='An interactive cheatsheet tool for the command-line.'
arch=('any')
url='https://github.com/denisidoro/navi'
@@ -16,17 +16,18 @@ source=("${pkgname}::git+${url}"
navi.install)
md5sums=('SKIP'
43cf44f1cd5b9a7bb8f247735a59ba91
- 27308a8ca0e77387464dbd7f1e0bcdd4
- )
+ 27308a8ca0e77387464dbd7f1e0bcdd4)
pkgver() {
cd "${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-check() {
- cd "${pkgname}"
- cargo test --release --locked
-}
+# Don't make rustc torture us even longer by re-compiling everything from scratch...
+# CI pipelines are a thing anyways.
+# check() {
+# cd "${pkgname}"
+# cargo test --release --locked
+# }
build() {
cd "${pkgname}"
diff --git a/navi.install b/navi.install
index 30d6b9c9e217..7a7b40fd25bb 100644
--- a/navi.install
+++ b/navi.install
@@ -1,3 +1,4 @@
post_install() {
- echo "Source the appropriate file from `~/.navi/shell` in your shell's dotfile. This enables proper populating of shell history and editting commands before executing them."
+ echo "\n\
+ Source the appropriate file from "~/.navi/shell" in your shell's dotfile. This enables proper populating of shell history and editting commands before executing them.\n"
}