summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-04-11 16:25:45 -0600
committerSumner Evans2020-04-11 16:25:45 -0600
commit8bafdd6cb5ea52c2bc6df3d236075974ae755a57 (patch)
tree0887a023eee56384c208e226f6be3ea6f2a76f1c
parentaf4a8861cae15da0f7dd527fd2971d7b82dd0dc4 (diff)
downloadaur-8bafdd6cb5ea52c2bc6df3d236075974ae755a57.tar.gz
Add ffmpeg as hard dependency
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate.sh2
4 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 291218ef3408..eae2c2f293e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = navidrome-bin
pkgdesc = Music Server and Streamer compatible with Subsonic/Airsonic
pkgver = 0.14.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.navidrome.org/
arch = x86_64
arch = armv6h
@@ -9,6 +9,7 @@ pkgbase = navidrome-bin
arch = aarch64
license = GPL3
depends = glibc
+ depends = ffmpeg
provides = navidrome
conflicts = navidrome
source_x86_64 = https://github.com/deluan/navidrome/releases/download/v0.14.2/navidrome_0.14.2_Linux_x86_64.tar.gz
diff --git a/.gitignore b/.gitignore
index 0756d3c9fd7c..6f7908bac53e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,3 @@
-download?job=build_logo
-
# Created by https://www.gitignore.io/api/archlinuxpackages
### ArchLinuxPackages ###
diff --git a/PKGBUILD b/PKGBUILD
index dbceaca44fb3..e30206ffbf65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgbase='navidrome-bin'
pkgname=(navidrome-bin)
pkgver='0.14.2'
-pkgrel=1
+pkgrel=2
pkgdesc='Music Server and Streamer compatible with Subsonic/Airsonic'
url='https://www.navidrome.org/'
license=('GPL3')
arch=(x86_64 armv6h armv7h aarch64)
provides=('navidrome')
conflicts=('navidrome')
-depends=('glibc')
+depends=('glibc' 'ffmpeg')
source_x86_64=('https://github.com/deluan/navidrome/releases/download/v0.14.2/navidrome_0.14.2_Linux_x86_64.tar.gz')
source_armv6h=('https://github.com/deluan/navidrome/releases/download/v0.14.2/navidrome_0.14.2_Linux_armv6.tar.gz')
source_armv7h=('https://github.com/deluan/navidrome/releases/download/v0.14.2/navidrome_0.14.2_Linux_armv7.tar.gz')
diff --git a/update.sh b/update.sh
index e8ad827f8489..945e9801da1d 100755
--- a/update.sh
+++ b/update.sh
@@ -29,7 +29,7 @@ license=('${LICENSE}')
arch=(x86_64 armv6h armv7h aarch64)
provides=('${EXECUTABLE_NAME}')
conflicts=('${EXECUTABLE_NAME}')
-depends=('glibc')
+depends=('glibc' 'ffmpeg')
source_x86_64=('https://github.com/deluan/navidrome/releases/download/v$1/navidrome_$1_Linux_x86_64.tar.gz')
source_armv6h=('https://github.com/deluan/navidrome/releases/download/v$1/navidrome_$1_Linux_armv6.tar.gz')
source_armv7h=('https://github.com/deluan/navidrome/releases/download/v$1/navidrome_$1_Linux_armv7.tar.gz')