summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThermionix2015-08-21 10:02:34 +1000
committerThermionix2015-08-21 10:02:34 +1000
commitc5eb3ac16b3a926da0434d169fa134779029dd0c (patch)
tree863c75784420c37b11fc9737326a5c167bf23a32
downloadaur-c5eb3ac16b3a926da0434d169fa134779029dd0c.tar.gz
new file: .SRCINFO
new file: PKGBUILD new file: navit.install
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rw-r--r--navit.install20
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b43a85e4acf9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = navit
+ pkgdesc = A modular turn-by-turn car navigation system
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://www.navit-project.org/
+ install = navit.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt
+ depends = cairo
+ depends = dbus-glib
+ depends = fribidi
+ depends = imlib2
+ depends = sdl_image
+ depends = gtk2
+ depends = gpsd
+ depends = postgresql-libs
+ optdepends = cegui>=0.5.0: OpenGL gui
+ optdepends = quesoglc: OpenGL gui
+ options = !libtool
+ source = http://downloads.sourceforge.net/navit/navit-0.2.0.tar.gz
+ sha256sums = 9c9e8f16d36c318cdc352ef3627ce70e4ac319bfd7261c2155b4c96d76716dca
+
+pkgname = navit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07ed06320705
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: TDY <tdy@archlinux.info>
+# Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
+# Contributor: Stefan Lohmaier <noneuss at gmail dot com
+# Contributor: Thermionix <thermionix at gmail dot com>
+
+pkgname=navit
+pkgver=v0.5.0_rc.1
+pkgrel=1
+pkgdesc="A modular turn-by-turn car navigation system"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.navit-project.org/"
+license=('GPL')
+depends=('glu' 'freeglut' 'dbus-glib' 'cairo' 'imlib2' 'sdl_image' 'gtk2' 'gpsd' 'postgresql-libs')
+optdepends=('cegui>=0.5.0: OpenGL gui' 'quesoglc: OpenGL gui')
+makedepends=('cmake')
+options=('!libtool')
+install=navit.install
+source=(http://downloads.sourceforge.net/$pkgname/${pkgver/_/-}.tar.gz)
+md5sums=('cb6ee913eea1fa06c90852e1dfbdcb94')
+
+build() {
+ cd "$srcdir/navit-gps-navit"*
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DCMAKE_LIBDIR=lib \
+ -Dgraphics/opengl=TRUE \
+ -DSAMPLE_MAP=FALSE
+ make
+}
+
+package() {
+ cd "$srcdir/navit-gps-navit"*
+ make DESTDIR=${pkgdir} install
+}
+
diff --git a/navit.install b/navit.install
new file mode 100644
index 000000000000..f88b6fef6d2a
--- /dev/null
+++ b/navit.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo "==> Additional setup is required"
+ echo " -> See http://wiki.navit-project.org/index.php/Configuration"
+ echo
+ echo "==> No maps are bundled with the install"
+ echo " -> See http://wiki.navit-project.org/index.php/Maps"
+ echo
+
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate
+}
+
+# vim:set ts=2 sw=2 et: