summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2015-06-08 20:47:46 +0200
committerRaimar Bühmann2015-06-08 20:47:46 +0200
commit1b47e7b420510969990fc5952480cc14c389a4fa (patch)
tree31a71168f46805e758e9bb567dce06a68da4ca45
downloadaur-1b47e7b420510969990fc5952480cc14c389a4fa.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..999a7d8c1e97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = navitconfigurator-git
+ pkgdesc = NavitConfigurator is an editor for configuring the open source navigation program Navit. It supports Android devices to test the result directly.
+ pkgver = 16.20130127
+ pkgrel = 3
+ url = https://sourceforge.net/projects/navitconfigurat/
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = qt4
+ depends = qtwebkit
+ provides = navitconfigurator
+ conflicts = navitconfigurator
+ source = git://git.code.sf.net/p/navitconfigurat/code
+ md5sums = SKIP
+
+pkgname = navitconfigurator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e6aec85957
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Raimar Bühmann <navitconfigurator@web.de>
+# Contributor: raimar <navitconfigurator@web.de>
+
+pkgname=navitconfigurator-git
+pkgver=16.20130127
+pkgrel=3
+pkgdesc="NavitConfigurator is an editor for configuring the open source navigation program Navit. It supports Android devices to test the result directly."
+arch=('i686' 'x86_64')
+url='https://sourceforge.net/projects/navitconfigurat/'
+license=('LGPL3')
+depends=('qt4' 'qtwebkit')
+makedepends=('git')
+provides=('navitconfigurator')
+conflicts=('navitconfigurator')
+source=('git://git.code.sf.net/p/navitconfigurat/code')
+md5sums=('SKIP')
+recommands=('adb-git')
+
+_gitroot="code"
+
+pkgver() {
+ cd $_gitroot
+ _versionTime=$(git show -s --format="%ci" | grep -o "....-..-.." | sed "s/-//g")
+ echo "$(git rev-list --count HEAD).$_versionTime"
+}
+
+build() {
+ cd $_gitroot
+ qmake-qt4
+ make
+}
+
+package() {
+ cd $_gitroot
+ make INSTALL_ROOT="$pkgdir" install
+}