summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-05-10 14:04:44 +0200
committerFrancesco Minnocci2021-05-10 14:04:44 +0200
commit5de71b1591fe2bfaba6482ef0e05f38e721322f6 (patch)
tree6f4b83c5cd36edcb4c7d233a81406c4bcd52de03
parent82c7fd09cf9c4450d019c802d03972094ab79f6c (diff)
downloadaur-5de71b1591fe2bfaba6482ef0e05f38e721322f6.tar.gz
Revert to xbuild for now(see comments).
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38eaff469cf7..8e16ab247890 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
pkgbase = nbfc
pkgdesc = Cross-platform fan control service for notebooks (STABLE & BETA releases)
pkgver = 1.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hirschmann/nbfc
install = nbfc.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = mono-msbuild
makedepends = nuget
depends = mono
- provides = nbfc
- provides = ec-probe
- conflicts = nbfc-beta
- conflicts = nbfc-git
source = https://github.com/hirschmann/nbfc/archive/1.6.3.tar.gz
source = nbfc
source = ec-probe
diff --git a/PKGBUILD b/PKGBUILD
index 3b1df3995f4b..9330326b2738 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,15 @@ pkgname=nbfc
pkgver=1.6.3
_pkgver=$(echo $pkgver | sed -r 's/_/-/g')
_pkgname=nbfc-${_pkgver}
-pkgrel=2
+pkgrel=3
pkgdesc="Cross-platform fan control service for notebooks (STABLE & BETA releases)"
url="https://github.com/hirschmann/nbfc"
arch=('i686' 'x86_64')
-conflicts=('nbfc-beta' 'nbfc-git')
license=('GPL3')
install=${pkgname}.install
depends=('mono')
-makedepends=('mono-msbuild' 'nuget')
-provides=('nbfc' 'ec-probe')
+# makedepends=('mono-msbuild' 'nuget')
+makedepends=('nuget')
source=("https://github.com/hirschmann/nbfc/archive/${_pkgver}.tar.gz"
"nbfc"
"ec-probe")
@@ -26,7 +25,8 @@ build() {
cd "${srcdir}/${_pkgname}/"
nuget restore NoteBookFanControl.sln
- msbuild -m /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
+ # msbuild -m /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
+ xbuild /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
}
package() {