summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErikas2018-10-07 17:31:38 +0300
committerErikas2018-10-07 17:31:38 +0300
commit7852d16e0b3e1e3612434203ee88932bb0afbbcb (patch)
tree277f220eb94486e5c711eb01d14155ef93ee89fd
parent8f6b15cc18627235f6e16f7862239d36a7b3b1f6 (diff)
downloadaur-7852d16e0b3e1e3612434203ee88932bb0afbbcb.tar.gz
Update to the latest release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD46
-rwxr-xr-xec-probe1
-rwxr-xr-xnbfc1
-rw-r--r--nbfc.install21
5 files changed, 55 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3a9884509a3..8eef7fa697d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = nbfc
pkgdesc = Cross-platform fan control service for notebooks (STABLE & BETA releases)
- pkgver = 1.5.3
- pkgrel = 4
+ pkgver = 1.6_beta1
+ pkgrel = 1
url = https://github.com/hirschmann/nbfc
+ install = nbfc.install
arch = i686
arch = x86_64
license = GPL3
@@ -12,8 +13,12 @@ pkgbase = nbfc
provides = ec-probe
conflicts = nbfc-beta
conflicts = nbfc-git
- source = https://github.com/hirschmann/nbfc/archive/1.5.3-beta.tar.gz
- md5sums = 55a344ee11d0ff5351bab0f4a583c36a
+ source = https://github.com/hirschmann/nbfc/archive/1.6-beta1.tar.gz
+ source = nbfc
+ source = ec-probe
+ md5sums = 1eee9e6e5a4cf2f6324e73000d5175f2
+ md5sums = b8c7ecbe7816a43deeb91426b1ba3fbe
+ md5sums = be72ba56253695932458f7cddc4a2194
pkgname = nbfc
diff --git a/PKGBUILD b/PKGBUILD
index 8d9e1cab9cae..678a0f1387dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,47 @@
# Maintainer: Erikas Rudinskas <erikmnkl@gmail.com>
pkgname=nbfc
-pkgver=1.5.3
-#_version="${pkgver}"
-_version="${pkgver}-beta"
-pkgrel=4
+pkgver=1.6_beta1
+_pkgver=$(echo $pkgver | sed -r 's/_/-/g')
+_pkgname=nbfc-${_pkgver}
+pkgrel=1
pkgdesc="Cross-platform fan control service for notebooks (STABLE & BETA releases)"
arch=("i686" "x86_64")
url="https://github.com/hirschmann/nbfc"
conflicts=('nbfc-beta' 'nbfc-git')
license=("GPL3")
+install=${pkgname}.install
depends=("mono")
-provides=("nbfc" "ec-probe")
-makedepends=("nuget")
-source=("https://github.com/hirschmann/nbfc/archive/${_version}.tar.gz")
-md5sums=("55a344ee11d0ff5351bab0f4a583c36a")
+makedepends=('ncurses<=6.0-4')
+provides=('nbfc' 'ec-probe')
+makedepends=('nuget')
+source=("https://github.com/hirschmann/nbfc/archive/${_pkgver}.tar.gz"
+ "nbfc"
+ "ec-probe")
+md5sums=("1eee9e6e5a4cf2f6324e73000d5175f2"
+ "b8c7ecbe7816a43deeb91426b1ba3fbe"
+ "be72ba56253695932458f7cddc4a2194")
build() {
- cd "${srcdir}/nbfc-${_version}/"
+ cd "${srcdir}/${_pkgname}/"
nuget restore NoteBookFanControl.sln
xbuild /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
}
package() {
-
- # Files/executables installation:
+ # Files installation:
mkdir -p "${pkgdir}/opt/nbfc"
- cp -R "${srcdir}/nbfc-${_version}/Linux/bin/Release/"* "${pkgdir}/opt/nbfc/"
- chmod -R 0755 "${pkgdir}/opt/nbfc"
+ cp -R "${srcdir}/${_pkgname}/Linux/bin/Release/"* "${pkgdir}/opt/nbfc/"
# Systemd services:
- install -D -m644 "${srcdir}/nbfc-${_version}/Linux/nbfc.service" "${pkgdir}/etc/systemd/system/nbfc.service"
- install -D -m644 "${srcdir}/nbfc-${_version}/Linux/nbfc-sleep.service" "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
-
- # Make nbfc executable from CLI:
- mkdir -p "${pkgdir}/usr/bin"
+ install -D -m644 "${srcdir}/${_pkgname}/Linux/nbfc.service" "${pkgdir}/etc/systemd/system/nbfc.service"
+ install -D -m644 "${srcdir}/${_pkgname}/Linux/nbfc-sleep.service" "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
+
# Executables:
- echo "mono /opt/nbfc/nbfc.exe \"\$@\" 2>&1 | sed 's/nbfc.exe/nbfc/g'" > "${pkgdir}/usr/bin/nbfc"
- chmod 0755 "${pkgdir}/usr/bin/nbfc"
- echo "mono /opt/nbfc/ec-probe.exe \"\$@\" 2>&1 | sed 's/ec-probe.exe/ec-probe/g'" > "${pkgdir}/usr/bin/ec-probe"
- chmod 0755 "${pkgdir}/usr/bin/ec-probe"
+ install -Dm755 "${srcdir}/nbfc" "${pkgdir}/usr/bin/nbfc"
+ install -Dm755 "${srcdir}/ec-probe" "${pkgdir}/usr/bin/ec-probe"
# License:
mkdir -p "${pkgdir}/usr/share/licenses/nbfc"
- install -D -m755 "${srcdir}/nbfc-${_version}/LICENSE.md" "${pkgdir}/usr/share/licenses/nbfc/LICENSE"
+ install -D -m755 "${srcdir}/${_pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/nbfc/LICENSE"
}
diff --git a/ec-probe b/ec-probe
new file mode 100755
index 000000000000..e408839e87aa
--- /dev/null
+++ b/ec-probe
@@ -0,0 +1 @@
+mono /opt/nbfc/ec-probe.exe "$@"
diff --git a/nbfc b/nbfc
new file mode 100755
index 000000000000..2901f87b97d5
--- /dev/null
+++ b/nbfc
@@ -0,0 +1 @@
+mono /opt/nbfc/nbfc.exe "$@"
diff --git a/nbfc.install b/nbfc.install
new file mode 100644
index 000000000000..3c3919355702
--- /dev/null
+++ b/nbfc.install
@@ -0,0 +1,21 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Consult Arch Linux Wiki if you are getting \"File Descriptor does not support writing\"."
+}
+
+post_upgrade() {
+ post_install
+}