summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErikas2017-09-11 11:15:17 +0300
committerErikas2017-09-11 11:15:17 +0300
commit950715049ef6da3d622b7ac4883ff9e7398edd74 (patch)
tree1576f018a8bb82bd6cbdcb723ccdca06978c96d8
downloadaur-950715049ef6da3d622b7ac4883ff9e7398edd74.tar.gz
nbfc-beta to nbfc + few fixes in PKGBUILD. Old package will be requested for deletion.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f59b52b4f54a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nbfc
+ pkgdesc = Cross-platform fan control service for notebooks (STABLE & BETA release)
+ pkgver = 1.5.3
+ pkgrel = 2
+ url = https://github.com/hirschmann/nbfc
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = nuget
+ depends = mono
+ provides = nbfc
+ conflicts = nbfc-beta
+ conflicts = nbfc-git
+ source = https://github.com/hirschmann/nbfc/archive/1.5.3-beta.tar.gz
+ md5sums = 55a344ee11d0ff5351bab0f4a583c36a
+
+pkgname = nbfc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..896e3d855080
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Erikas Rudinskas <erikmnkl@gmail.com>
+
+pkgname=nbfc
+pkgver=1.5.3
+#_version="${pkgver}"
+_version="${pkgver}-beta"
+pkgrel=2
+pkgdesc="Cross-platform fan control service for notebooks (STABLE & BETA release)"
+arch=("i686" "x86_64")
+url="https://github.com/hirschmann/nbfc"
+conflicts=('nbfc-beta' 'nbfc-git')
+license=("GPL3")
+depends=("mono")
+provides=('nbfc')
+makedepends=("nuget")
+source=("https://github.com/hirschmann/nbfc/archive/${_version}.tar.gz")
+md5sums=("55a344ee11d0ff5351bab0f4a583c36a")
+
+build() {
+ cd "${srcdir}/nbfc-${_version}/"
+ nuget restore NoteBookFanControl.sln
+ xbuild /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
+}
+
+package() {
+
+ # Files/executables installation:
+ mkdir -p "${pkgdir}/opt/nbfc"
+ cp -R "${srcdir}/nbfc-${_version}/Linux/bin/Release/"* "${pkgdir}/opt/nbfc/"
+ chmod -R 0755 "${pkgdir}/opt/nbfc"
+
+ # Systemd services:
+ install -D -m644 "${srcdir}/nbfc-${_version}/Linux/nbfc.service" "${pkgdir}/etc/systemd/system/nbfc.service"
+ install -D -m644 "${srcdir}/nbfc-${_version}/Linux/nbfc-sleep.service" "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
+
+ # Make nbfc executable from CLI:
+ mkdir -p "${pkgdir}/usr/bin"
+ #
+ echo "/opt/nbfc/./nbfc.exe \"\$@\" 2>&1 | sed 's/nbfc.exe/nbfc/g'" > "${pkgdir}/usr/bin/nbfc"
+ chmod 0755 "${pkgdir}/usr/bin/nbfc"
+
+ # License:
+ mkdir -p "${pkgdir}/usr/share/licenses/nbfc"
+ install -D -m755 "${srcdir}/nbfc-${_version}/LICENSE.md" "${pkgdir}/usr/share/licenses/nbfc/LICENSE"
+}