summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErikas2017-09-17 03:45:00 +0300
committerErikas2017-09-17 03:45:00 +0300
commit3510e1ca1a9dbc0197a931f10a753ad7fa0e544c (patch)
tree1a0ef113f4b1736412935335dc5e7258ea01e6f1
downloadaur-3510e1ca1a9dbc0197a931f10a753ad7fa0e544c.tar.gz
useful commit message
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9974deec4bce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nbfc-git
+ pkgdesc = Cross-platform fan control service for notebooks (Development version)
+ pkgver = 1.5.3.r29.g04dce5e
+ pkgrel = 1
+ url = https://github.com/hirschmann/nbfc
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = nuget
+ depends = mono
+ provides = nbfc
+ provides = ec-probe
+ conflicts = nbfc-beta
+ conflicts = nbfc
+ source = nbfc-git::git+https://github.com/hirschmann/nbfc.git
+ md5sums = SKIP
+
+pkgname = nbfc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c23be64c2c6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Erikas Rudinskas <erikmnkl@gmail.com>
+
+pkgname=nbfc-git
+pkgver=1.5.3.r29.g04dce5e
+pkgrel=1
+pkgdesc="Cross-platform fan control service for notebooks (Development version)"
+arch=("i686" "x86_64")
+url="https://github.com/hirschmann/nbfc"
+conflicts=('nbfc-beta' 'nbfc')
+license=("GPL3")
+depends=("mono")
+provides=("nbfc" "ec-probe")
+makedepends=("nuget")
+source=("${pkgname}::git+https://github.com/hirschmann/nbfc.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/.beta//g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ nuget restore NoteBookFanControl.sln
+ xbuild /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
+}
+
+package() {
+
+ # Files/executables installation:
+ mkdir -p "${pkgdir}/opt/nbfc"
+ cp -R "${srcdir}/${pkgname}/Linux/bin/Release/"* "${pkgdir}/opt/nbfc/"
+ chmod -R 0755 "${pkgdir}/opt/nbfc"
+
+ # Systemd services:
+ install -D -m644 "${srcdir}/${pkgname}/Linux/nbfc.service" "${pkgdir}/etc/systemd/system/nbfc.service"
+ install -D -m644 "${srcdir}/${pkgname}/Linux/nbfc-sleep.service" "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
+
+ # Make nbfc executable from CLI:
+ mkdir -p "${pkgdir}/usr/bin"
+ # Executables:
+ echo "mono /opt/nbfc/nbfc.exe \"\$@\" 2>&1 | sed 's/nbfc.exe/nbfc/g'" > "${pkgdir}/usr/bin/nbfc"
+ chmod 0755 "${pkgdir}/usr/bin/nbfc"
+ echo "mono /opt/nbfc/ec-probe.exe \"\$@\" 2>&1 | sed 's/ec-probe.exe/ec-probe/g'" > "${pkgdir}/usr/bin/ec-probe"
+ chmod 0755 "${pkgdir}/usr/bin/ec-probe"
+
+ # License:
+ mkdir -p "${pkgdir}/usr/share/licenses/nbfc"
+ install -D -m755 "${srcdir}/${pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/nbfc/LICENSE"
+}