summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-05-05 13:15:52 +0200
committerFrancesco Minnocci2021-05-05 13:15:52 +0200
commitc44c235542ed860ce9ec45491f97819f7fff12c4 (patch)
tree7041c26fd1abfcd1af3069f0a68b6e83f384624e
parent50d652c2fc078cc3bf2cdf30f9193a29ecfbc410 (diff)
downloadaur-c44c235542ed860ce9ec45491f97819f7fff12c4.tar.gz
Add mono-msbuild to makedeps and add parallel compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85cb39387d6e..750b07f01922 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = nbfc-git
pkgdesc = Cross-platform fan control service for notebooks (Development version)
pkgver = 1.6.3.r40.gfc9fb97
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hirschmann/nbfc
install = nbfc-git.install
arch = i686
arch = x86_64
license = GPL3
makedepends = nuget
+ makedepends = mono-msbuild
makedepends = git
depends = mono
provides = nbfc
@@ -22,4 +23,3 @@ pkgbase = nbfc-git
md5sums = 81686043a7fc44d620a00a171c917936
pkgname = nbfc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c61015b873c..35768dba980e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,54 @@
-# Maintainer: Erikas Rudinskas <erikmnkl@gmail.com>
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: Erikas Rudinskas <erikmnkl@gmail.com>
pkgname=nbfc-git
pkgver=1.6.3.r40.gfc9fb97
-pkgrel=1
+pkgrel=2
pkgdesc='Cross-platform fan control service for notebooks (Development version)'
+url="https://github.com/hirschmann/nbfc"
arch=('i686' 'x86_64')
-url='https://github.com/hirschmann/nbfc'
conflicts=('nbfc-beta' 'nbfc')
-license=("GPL3")
+license=('GPL3')
install=${pkgname}.install
-depends=("mono")
-makedepends=('nuget' 'git')
+depends=('mono')
+makedepends=('nuget' 'mono-msbuild' 'git')
provides=('nbfc' 'ec-probe')
source=("${pkgname}::git+https://github.com/hirschmann/nbfc.git"
"nbfc"
- "ec-probe")
+ "ec-probe")
md5sums=("SKIP"
"2dc636f29fa935ea427e6e67bdb9f65d"
"81686043a7fc44d620a00a171c917936")
pkgver() {
cd "${srcdir}/${pkgname}"
+
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/.beta//g'
}
build() {
cd "${srcdir}/${pkgname}"
+
nuget restore NoteBookFanControl.sln
- xbuild /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
+ msbuild -m /t:Build /p:Configuration=ReleaseLinux NoteBookFanControl.sln
}
package() {
+ cd "${srcdir}/${pkgname}"
+
# Files installation:
mkdir -p "${pkgdir}/opt/nbfc"
- cp -R "${srcdir}/${pkgname}/Linux/bin/Release/"* "${pkgdir}/opt/nbfc/"
+ cp -R Linux/bin/Release/* "${pkgdir}/opt/nbfc/"
# Systemd services:
- install -D -m644 "${srcdir}/${pkgname}/Linux/nbfc.service" "${pkgdir}/etc/systemd/system/nbfc.service"
- install -D -m644 "${srcdir}/${pkgname}/Linux/nbfc-sleep.service" "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
-
+ install -D -m644 Linux/nbfc.service "${pkgdir}/etc/systemd/system/nbfc.service"
+ install -D -m644 Linux/nbfc-sleep.service "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
+
# Executables:
install -Dm755 "${srcdir}/nbfc" "${pkgdir}/usr/bin/nbfc"
install -Dm755 "${srcdir}/ec-probe" "${pkgdir}/usr/bin/ec-probe"
# License:
mkdir -p "${pkgdir}/usr/share/licenses/nbfc"
- install -D -m755 "${srcdir}/${pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/nbfc/LICENSE"
+ install -D -m755 LICENSE.md "${pkgdir}/usr/share/licenses/nbfc/LICENSE"
}