summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErikas2018-08-15 08:06:59 +0300
committerErikas2018-08-15 08:06:59 +0300
commitcfd5ee7747cca5cc6faa299363e3e94b50f556c2 (patch)
treee551acdba80e79f964b4b07384e11f8e64ffe67c
parent96549deb0a651e529cc638dabbf9651789af4a81 (diff)
downloadaur-cfd5ee7747cca5cc6faa299363e3e94b50f556c2.tar.gz
Update to fix issue #535
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD41
-rwxr-xr-xec-probe1
-rwxr-xr-xnbfc1
4 files changed, 27 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34520d2ebc8c..d486b3ae923c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nbfc-git
pkgdesc = Cross-platform fan control service for notebooks (Development version)
- pkgver = 1.5.3.r69.gd66bb13
+ pkgver = 1.5.3.r71.gf45d282
pkgrel = 1
url = https://github.com/hirschmann/nbfc
arch = i686
@@ -13,7 +13,11 @@ pkgbase = nbfc-git
conflicts = nbfc-beta
conflicts = nbfc
source = nbfc-git::git+https://github.com/hirschmann/nbfc.git
+ source = nbfc
+ source = ec-probe
md5sums = SKIP
+ md5sums = b8c7ecbe7816a43deeb91426b1ba3fbe
+ md5sums = be72ba56253695932458f7cddc4a2194
pkgname = nbfc-git
diff --git a/PKGBUILD b/PKGBUILD
index 0823381eaadd..a7ee370feb02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: Erikas Rudinskas <erikmnkl@gmail.com>
pkgname=nbfc-git
-pkgver=1.5.3.r69.gd66bb13
+pkgver=1.5.3.r71.gf45d282
pkgrel=1
-pkgdesc="Cross-platform fan control service for notebooks (Development version)"
-arch=("i686" "x86_64")
-url="https://github.com/hirschmann/nbfc"
+pkgdesc='Cross-platform fan control service for notebooks (Development version)'
+arch=('i686' 'x86_64')
+url='https://github.com/hirschmann/nbfc'
conflicts=('nbfc-beta' 'nbfc')
-license=("GPL3")
-depends=("mono")
-makedepends=("ncurses<=6.0-4")
-provides=("nbfc" "ec-probe")
-makedepends=("nuget")
-source=("${pkgname}::git+https://github.com/hirschmann/nbfc.git")
-md5sums=("SKIP")
+license=('GPL3')
+depends=('mono')
+makedepends=('ncurses<=6.0-4')
+provides=('nbfc' 'ec-probe')
+makedepends=('nuget')
+source=("${pkgname}::git+https://github.com/hirschmann/nbfc.git"
+ "nbfc"
+ "ec-probe")
+md5sums=("SKIP"
+ "b8c7ecbe7816a43deeb91426b1ba3fbe"
+ "be72ba56253695932458f7cddc4a2194")
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -27,22 +31,17 @@ build() {
}
package() {
-
- # Files/executables installation:
+ # Files installation:
mkdir -p "${pkgdir}/opt/nbfc"
cp -R "${srcdir}/${pkgname}/Linux/bin/Release/"* "${pkgdir}/opt/nbfc/"
- chmod -R 0755 "${pkgdir}/opt/nbfc"
# Systemd services:
install -D -m644 "${srcdir}/${pkgname}/Linux/nbfc.service" "${pkgdir}/etc/systemd/system/nbfc.service"
install -D -m644 "${srcdir}/${pkgname}/Linux/nbfc-sleep.service" "${pkgdir}/etc/systemd/system/nbfc-sleep.service"
-
- # Make nbfc executable from CLI:
- mkdir -p "${pkgdir}/usr/bin"
- echo "mono /opt/nbfc/nbfc.exe \"\$@\" 2>&1 | sed 's/nbfc.exe/nbfc/g'" > "${pkgdir}/usr/bin/nbfc"
- chmod 0755 "${pkgdir}/usr/bin/nbfc"
- echo "mono /opt/nbfc/ec-probe.exe \"\$@\" 2>&1 | sed 's/ec-probe.exe/ec-probe/g'" > "${pkgdir}/usr/bin/ec-probe"
- chmod 0755 "${pkgdir}/usr/bin/ec-probe"
+
+ # Executables:
+ install -Dm755 "${srcdir}/nbfc" "${pkgdir}/usr/bin/nbfc"
+ install -Dm755 "${srcdir}/ec-probe" "${pkgdir}/usr/bin/ec-probe"
# License:
mkdir -p "${pkgdir}/usr/share/licenses/nbfc"
diff --git a/ec-probe b/ec-probe
new file mode 100755
index 000000000000..e408839e87aa
--- /dev/null
+++ b/ec-probe
@@ -0,0 +1 @@
+mono /opt/nbfc/ec-probe.exe "$@"
diff --git a/nbfc b/nbfc
new file mode 100755
index 000000000000..2901f87b97d5
--- /dev/null
+++ b/nbfc
@@ -0,0 +1 @@
+mono /opt/nbfc/nbfc.exe "$@"