summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-05-11 23:06:44 +0200
committerFrancesco Minnocci2021-05-11 23:06:44 +0200
commited6636af0cf699591f26288f99a7f8f773fb6c39 (patch)
tree3dc70958f5810f7c5569ddb0f2f80a7f3de8dd56
downloadaur-ed6636af0cf699591f26288f99a7f8f773fb6c39.tar.gz
Initial package upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..431123aefad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nbfc-linux
+ pkgdesc = Lightweight C port of NoteBook FanControl (no Mono required)
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/braph/nbfc-linux
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = lm_sensors
+ optdepends = dmidecode: for getting recommended notebook configurations
+ provides = nbfc
+ conflicts = nbfc
+ source = https://github.com/braph/nbfc-linux/archive/refs/tags/0.0.1.tar.gz
+ sha512sums = fb23e610941e7c9a67354d1dcdd6c27c324c9eef87dc389ea05ff1db7be7ba3d89b9cb95677c90de487810e0658f0c798d9821c0ebd2c9c2421ae6db6f612382
+
+pkgname = nbfc-linux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5386a0ca9cb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: Benjamin Abendroth <braph93@gmx.de>
+
+pkgname=nbfc-linux
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Lightweight C port of NoteBook FanControl (no Mono required)"
+arch=('i686' 'x86_64')
+url="https://github.com/braph/nbfc-linux"
+optdepends=('dmidecode: for getting recommended notebook configurations')
+makedepends=('lm_sensors')
+license=('GPL3')
+conflicts=('nbfc')
+provides=('nbfc')
+source=("https://github.com/braph/nbfc-linux/archive/refs/tags/${pkgver}.tar.gz")
+sha512sums=('fb23e610941e7c9a67354d1dcdd6c27c324c9eef87dc389ea05ff1db7be7ba3d89b9cb95677c90de487810e0658f0c798d9821c0ebd2c9c2421ae6db6f612382')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+}
+# vim:set ts=2 sw=2 et: