summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2023-06-20 08:33:47 +1000
committerMark Blakeney2023-06-20 08:33:47 +1000
commitada329939d65aa16f94eeb79e7f75cdd6abe9c27 (patch)
treef292b1e86bc4547e2aa2c89fe0733b25bac7b1e9
parent97e18bc3bf86d47a675127df049c004d0af400e1 (diff)
downloadaur-ada329939d65aa16f94eeb79e7f75cdd6abe9c27.tar.gz
Update to 1.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 062bbfebfd35..18469f5206fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nbtopy
pkgdesc = Converts Jupyter notebook files to Python files
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
url = https://github.com/bulletmark/nbtopy
arch = any
@@ -9,8 +9,9 @@ pkgbase = nbtopy
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python>=3.6
- source = nbtopy-1.0.tar.gz::https://github.com/bulletmark/nbtopy/archive/1.0.tar.gz
- sha1sums = 29d9b922f3fd97c9860ac3ecf83d998be86cf276
+ source = nbtopy-1.1.tar.gz::https://github.com/bulletmark/nbtopy/archive/1.1.tar.gz
+ sha1sums = 9674844612dd60699f11b415e730a56c5beeb382
pkgname = nbtopy
diff --git a/PKGBUILD b/PKGBUILD
index 8e82fee01ca5..59fb108d77a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=nbtopy
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Converts Jupyter notebook files to Python files"
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
depends=("python>=3.6")
-makedepends=(python-setuptools python-build python-installer python-wheel)
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('29d9b922f3fd97c9860ac3ecf83d998be86cf276')
+sha1sums=('9674844612dd60699f11b415e730a56c5beeb382')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {