summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-07 21:43:05 -0500
committerCarlos Aznarán Laos2022-10-07 21:43:05 -0500
commit29c57b486c568f776350de1cd314fe37800772a6 (patch)
tree9814b59932a83694fa80a3496ebde93989481f64
downloadaur-29c57b486c568f776350de1cd314fe37800772a6.tar.gz
Bump version to 2.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94b3a794b720
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nbtutor
+ pkgdesc = Visualize Python code execution in Jupyter Notebook cells
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/lgpage/nbtutor
+ arch = any
+ license = custom:BSD-3-clause
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = jupyter-notebook
+ source = nbtutor-2.0.3.tar.gz::https://github.com/lgpage/nbtutor/archive/2.0.3.tar.gz
+ sha512sums = f55b69ce96c449ad7a1a623135ef94c6b54894680925cce14ea08ab5d1f409a17cd6c59876a8a2f6e8b63206b58c5afb2610c60c2fb2aebe0c0a8084599aebfd
+
+pkgname = nbtutor
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff271a83ba5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+pkgname=nbtutor
+pkgdesc="Visualize Python code execution in Jupyter Notebook cells"
+pkgver=2.0.3
+pkgrel=1
+arch=(any)
+url="https://github.com/lgpage/${pkgname}"
+license=('custom:BSD-3-clause')
+depends=(jupyter-notebook)
+makedepends=(python-setuptools)
+checkdepends=(python-pytest)
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('f55b69ce96c449ad7a1a623135ef94c6b54894680925cce14ea08ab5d1f409a17cd6c59876a8a2f6e8b63206b58c5afb2610c60c2fb2aebe0c0a8084599aebfd')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${pkgname}-${pkgver}
+ python -m pytest
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENCE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}