summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNova Wittam2021-10-05 12:04:16 +0100
committerNova Wittam2021-10-05 12:04:16 +0100
commit18ab41f58ea489f1d2e23ee058262cce48282b32 (patch)
tree5eb61b3ec04ab90581dcd0e62336d776ee220b77
downloadaur-18ab41f58ea489f1d2e23ee058262cce48282b32.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--nbtvol-1.0.2.tar.gzbin0 -> 10240 bytes
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e01ab28335ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = nbtvol
+ pkgdesc = A simple set of shell scripts and C programs to control bluetooth device volume through PulseAudio
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/Not-Super-Nova/nbtvol
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc>=11.1.0-1
+ makedepends = gcc-libs>=11.1.0-1
+ depends = systemd>=248.3-3
+ depends = dbus>=1.12.20-1
+ depends = sed>=4.8-1
+ depends = grep>=3.6-1
+ depends = coreutils>=8.32-1
+ depends = libpulse>=14.2-3
+ depends = bash>=5.1.008-3
+ source = nbtvol-1.0.2.tar.gz
+ sha512sums = b8183adc4d0ab5eb5c231dc503e18758e5a03c0582b30c1e14c8f06257532c417686669c89ca5e79608971a7fe0137c7dedfccfd3b43f3885e07d744415ee93b
+
+pkgname = nbtvol
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6239e066db43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Nova Wittam <novawittam@gmail.com>
+pkgname=nbtvol
+pkgver=1.0.2
+pkgrel=1
+epoch=
+pkgdesc="A simple set of shell scripts and C programs to control bluetooth device volume through PulseAudio"
+arch=("x86_64")
+url="https://github.com/Not-Super-Nova/nbtvol"
+license=('GPL3')
+groups=()
+depends=("systemd>=248.3-3" "dbus>=1.12.20-1" "sed>=4.8-1" "grep>=3.6-1" "coreutils>=8.32-1" "libpulse>=14.2-3" "bash>=5.1.008-3")
+makedepends=("gcc>=11.1.0-1" "gcc-libs>=11.1.0-1")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz")
+noextract=()
+sha512sums=("b8183adc4d0ab5eb5c231dc503e18758e5a03c0582b30c1e14c8f06257532c417686669c89ca5e79608971a7fe0137c7dedfccfd3b43f3885e07d744415ee93b")
+validpgpkeys=()
+
+build() {
+ gcc main.c -o ./volwatcher
+}
+
+package() {
+ mkdir -p ~/.local/bin
+ cp ./volwatcher ./btVolume ./btVolumeWrapper ~/.local/bin/
+}
diff --git a/nbtvol-1.0.2.tar.gz b/nbtvol-1.0.2.tar.gz
new file mode 100644
index 000000000000..840c62b646cd
--- /dev/null
+++ b/nbtvol-1.0.2.tar.gz
Binary files differ