summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2018-10-11 10:36:34 +0200
committermschubert2018-10-11 10:36:34 +0200
commit016585d3a47c08f54740bf8aaf5102291cf4c709 (patch)
tree138c988267d72694500c60a98447017ed8be84e7
parent507264d4d43a9f71657aff828ad6288855100964 (diff)
downloadaur-016585d3a47c08f54740bf8aaf5102291cf4c709.tar.gz
fix deps, build; update to 21.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 22 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a66e4407139f..b0ec8fb08b03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,33 @@
-# Generated by mksrcinfo v8
-# Tue Feb 2 20:23:11 UTC 2016
pkgbase = ncbi-toolkit
pkgdesc = Applications, scripts and C++ libraries for the analysis of biological data
- pkgver = 12.0.0
+ pkgver = 21.0.0
pkgrel = 1
- url = http://www.ncbi.nlm.nih.gov/books/NBK7160/
+ url = https://ncbi.github.io/cxx-toolkit/
arch = i686
arch = x86_64
license = custom
makedepends = autoconf
- makedepends = gcc<4.9
depends = python2
depends = pcre
depends = sqlite
- depends = lzo2
+ depends = lzo
depends = libtiff
depends = giflib
depends = libxpm
- depends = libmysqlclient
+ depends = libmariadbclient
depends = libpng
depends = gnutls
depends = libxml2
depends = libxslt
optdepends = fltk
optdepends = wxgtk
- optdepends = db48
optdepends = fcgi
provides = blast+-bin
conflicts = blast+-bin
- source = ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/12_0_0/ncbi_cxx--12_0_0.tar.gz
+ source = ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/2018/Apr_2_2018/ncbi_cxx--21_0_0.tar.gz
source = LICENSE
- md5sums = eb90379fb6a35dd9e5c928b49c4d8a74
- md5sums = 344b3873e649094cf2dbaac7b55cafbc
+ sha256sums = 48cc3ae24ca63d1ab1be148e7525e8c5b9f4eaa5eb36d172800784b640a84a4f
+ sha256sums = 78bbf3f310ff43f1b5f711e7221d51da1e6f055831bd6c6941e0650bf1261df2
pkgname = ncbi-toolkit
diff --git a/PKGBUILD b/PKGBUILD
index b63c0c000665..2eeefb830d05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,40 @@
# Maintainer: Michael Schubert <mschu.dev at gmail>
# Contributor: Mick Elliot <micke at sfu dot ca>
-
pkgname=ncbi-toolkit
-pkgver=12.0.0
+pkgver=21.0.0
_pkgver=${pkgver//./_}
pkgrel=1
pkgdesc="Applications, scripts and C++ libraries for the analysis of biological data"
arch=('i686' 'x86_64')
-url="http://www.ncbi.nlm.nih.gov/books/NBK7160/"
+url="https://ncbi.github.io/cxx-toolkit/"
license=('custom')
-depends=('python2' 'pcre' 'sqlite' 'lzo2' 'libtiff' 'giflib' 'libxpm' 'libmysqlclient' 'libpng' 'gnutls' 'libxml2' 'libxslt')
-optdepends=('fltk' 'wxgtk' 'db48' 'fcgi')
-makedepends=('autoconf' 'gcc<4.9')
+depends=('python2' 'pcre' 'sqlite' 'lzo' 'libtiff' 'giflib' 'libxpm' 'libmariadbclient' 'libpng' 'gnutls' 'libxml2' 'libxslt')
+optdepends=('fltk' 'wxgtk' 'fcgi')
+makedepends=('autoconf')
provides=('blast+-bin')
conflicts=('blast+-bin')
-source=("ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/$_pkgver/ncbi_cxx--$_pkgver.tar.gz" "LICENSE")
-md5sums=('eb90379fb6a35dd9e5c928b49c4d8a74'
- '344b3873e649094cf2dbaac7b55cafbc')
+source=("ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/2018/Apr_2_2018/ncbi_cxx--$_pkgver.tar.gz" "LICENSE")
+sha256sums=('48cc3ae24ca63d1ab1be148e7525e8c5b9f4eaa5eb36d172800784b640a84a4f'
+ '78bbf3f310ff43f1b5f711e7221d51da1e6f055831bd6c6941e0650bf1261df2')
build() {
- # for details see http://www.ncbi.nlm.nih.gov/books/NBK7167/#ch_config.Configuring_with_UNI
- # flags that do not work: --with-dll --with-bdb
- FLAGS="--without-debug --with-bin-release --with-bincopy --with-static \
- --with-optimization --with-autodep --with-mt --prefix=$pkgdir/usr \
- --libdir=$pkgdir/usr/lib --with-build-root=$srcdir/build \
- --without-bdb --without-internal --with-optimization"
+ # for details see https://ncbi.github.io/cxx-toolkit/pages/ch_config#ch_config.UNIX
+ FLAGS="--without-debug --with-bin-release --with-dll --without-static \
+ --with-optimization --with-autodep --with-mt --prefix=/usr \
+ --with-build-root=$srcdir/build --without-bdb --without-internal"
if [ $CARCH = "x86_64" ]; then
FLAGS="$FLAGS --with-64"
fi
cd "$srcdir/ncbi_cxx--$_pkgver"
+ rm -f "$srcdir"/build/inc/ncbiconf_unix.h # in case of previous build
./configure $FLAGS
-
- find src/sra/sdk -name "*.c" -exec sed -i "/curl\/types.h/d" {} \;
-
make
}
package() {
cd "$srcdir/ncbi_cxx--$_pkgver"
-
install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/license"
- mv "$srcdir/build/lib/ncbi" "$pkgdir/usr/lib/" # make install error otherwise
- make install
+ make prefix="$pkgdir"/usr libdir="$pkgdir"/usr/lib install
+ find "$pkgdir"/usr/bin -name "*test*" -delete
}