summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2016-02-02 20:23:19 +0000
committermschubert2016-02-02 20:23:19 +0000
commit507264d4d43a9f71657aff828ad6288855100964 (patch)
tree80dd31a80e22bb00822d1b05988771e659893d04
parent3cef264b4d2bf5cabefed0288c7fd295bfe0c7ca (diff)
downloadaur-507264d4d43a9f71657aff828ad6288855100964.tar.gz
add req for gcc<4.9
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4aa69a69f16..a66e4407139f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 20:23:11 UTC 2016
pkgbase = ncbi-toolkit
pkgdesc = Applications, scripts and C++ libraries for the analysis of biological data
- pkgver = 9.0.0
+ pkgver = 12.0.0
pkgrel = 1
url = http://www.ncbi.nlm.nih.gov/books/NBK7160/
arch = i686
arch = x86_64
license = custom
makedepends = autoconf
+ makedepends = gcc<4.9
depends = python2
depends = pcre
depends = sqlite
@@ -25,9 +28,9 @@ pkgbase = ncbi-toolkit
optdepends = fcgi
provides = blast+-bin
conflicts = blast+-bin
- source = ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/9_0_0/ncbi_cxx--9_0_0.tar.gz
+ source = ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/12_0_0/ncbi_cxx--12_0_0.tar.gz
source = LICENSE
- md5sums = 46cbd232e024690ae617d1c44f3380b4
+ md5sums = eb90379fb6a35dd9e5c928b49c4d8a74
md5sums = 344b3873e649094cf2dbaac7b55cafbc
pkgname = ncbi-toolkit
diff --git a/PKGBUILD b/PKGBUILD
index 3c39c06dcdbd..b63c0c000665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Mick Elliot <micke at sfu dot ca>
pkgname=ncbi-toolkit
-pkgver=9.0.0
+pkgver=12.0.0
_pkgver=${pkgver//./_}
pkgrel=1
pkgdesc="Applications, scripts and C++ libraries for the analysis of biological data"
@@ -11,15 +11,14 @@ url="http://www.ncbi.nlm.nih.gov/books/NBK7160/"
license=('custom')
depends=('python2' 'pcre' 'sqlite' 'lzo2' 'libtiff' 'giflib' 'libxpm' 'libmysqlclient' 'libpng' 'gnutls' 'libxml2' 'libxslt')
optdepends=('fltk' 'wxgtk' 'db48' 'fcgi')
-makedepends=('autoconf')
+makedepends=('autoconf' 'gcc<4.9')
provides=('blast+-bin')
conflicts=('blast+-bin')
source=("ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/ARCHIVE/$_pkgver/ncbi_cxx--$_pkgver.tar.gz" "LICENSE")
-md5sums=('46cbd232e024690ae617d1c44f3380b4'
+md5sums=('eb90379fb6a35dd9e5c928b49c4d8a74'
'344b3873e649094cf2dbaac7b55cafbc')
-build()
-{
+build() {
# for details see http://www.ncbi.nlm.nih.gov/books/NBK7167/#ch_config.Configuring_with_UNI
# flags that do not work: --with-dll --with-bdb
FLAGS="--without-debug --with-bin-release --with-bincopy --with-static \
@@ -45,4 +44,3 @@ package() {
mv "$srcdir/build/lib/ncbi" "$pkgdir/usr/lib/" # make install error otherwise
make install
}
-