summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorapolih2016-06-21 14:02:06 -0500
committerapolih2016-06-21 14:02:06 -0500
commit361d37f0c27359037cf61384514d09315237c3b4 (patch)
tree03e76ebc9d764cec7b9167dbac812b0036f0a20e
parent39c99d1aeab0df45924450047fdef90491d80546 (diff)
downloadaur-361d37f0c27359037cf61384514d09315237c3b4.tar.gz
updated pkgver
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--ncbi-vdb-2.6.2.patch16
-rw-r--r--ncbi-vdb.patch16
4 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69a577863e54..76f18a19f32d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncbi-vdb
pkgdesc = The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives.
- pkgver = 2.6.2
+ pkgver = 2.6.3
pkgrel = 1
url = https://github.com/ncbi/ncbi-vdb
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = ncbi-vdb
depends = ngs
depends = hdf5
provides = ncbi-vdb
- source = https://github.com/ncbi/ncbi-vdb/archive/2.6.2.tar.gz
- source = ncbi-vdb-2.6.2.patch
- sha256sums = c310edacd1a4f98a5cfab702f3eede98977ef64831f002fddd7728ed7e2034f4
- sha256sums = 4062cc8018e26192eaaff6d27205a3854e223f2e9c75b2d935a283bf85e1f99c
+ source = https://github.com/ncbi/ncbi-vdb/archive/2.6.3.tar.gz
+ source = ncbi-vdb.patch
+ sha256sums = 49bb251207b22d3136129f7f718985e0a9acb2e08d382d52e3ab7400544202a6
+ sha256sums = db379579bae63b67d1a58ead406e39123374d6f5ff195a7ab41bb4e10d6f98fb
pkgname = ncbi-vdb
diff --git a/PKGBUILD b/PKGBUILD
index b62f10da51aa..98cbdc76f0e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aaron Baker <aa{last name}99{at}gmail{dt}org>
pkgname=ncbi-vdb
-pkgver=2.6.2
+pkgver=2.6.3
pkgrel=1
pkgdesc="The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives."
arch=('x86_64')
@@ -10,13 +10,14 @@ url="https://github.com/ncbi/ncbi-vdb"
depends=('libxml2' 'ngs' 'hdf5')
provides=('ncbi-vdb')
license=('custom:PublicDomain')
-source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz" "$pkgname-$pkgver.patch")
-sha256sums=('c310edacd1a4f98a5cfab702f3eede98977ef64831f002fddd7728ed7e2034f4' '4062cc8018e26192eaaff6d27205a3854e223f2e9c75b2d935a283bf85e1f99c')
+source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz" "$pkgname.patch")
+sha256sums=('49bb251207b22d3136129f7f718985e0a9acb2e08d382d52e3ab7400544202a6' 'db379579bae63b67d1a58ead406e39123374d6f5ff195a7ab41bb4e10d6f98fb')
prepare(){
cd "${pkgname}-${pkgver}"
- # stop NCBI root checks for great good
- patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+ # ncbi build process frequently checks if we are root user which interferes
+ # with makepkg use of fakeroot
+ patch -p1 -i $srcdir/$pkgname.patch
}
build(){
diff --git a/ncbi-vdb-2.6.2.patch b/ncbi-vdb-2.6.2.patch
deleted file mode 100644
index 7ed02c4d14e6..000000000000
--- a/ncbi-vdb-2.6.2.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -aur ncbi-vdb-2.6.2/build/Makefile.install ncbi-vdb-2.6.2-patch/build/Makefile.install
---- ncbi-vdb-2.6.2/build/Makefile.install 2016-04-21 18:52:55.000000000 +0000
-+++ ncbi-vdb-2.6.2-patch/build/Makefile.install 2016-05-06 19:53:56.615385102 +0000
-@@ -66,12 +66,6 @@
- PROFILE_FILE = $(ROOT)/etc/profile.d/ncbi-vdb
- KONFIG_DIR = $(ROOT)/etc/ncbi/
-
--ifeq (linux, $(OS))
-- ifeq (0, $(shell id -u))
-- LINUX_ROOT = true
-- endif
--endif
--
- install: copylibs copyincludes
- ifeq (true, $(LINUX_ROOT))
- @ # install symlink to includes
diff --git a/ncbi-vdb.patch b/ncbi-vdb.patch
new file mode 100644
index 000000000000..15be45225640
--- /dev/null
+++ b/ncbi-vdb.patch
@@ -0,0 +1,16 @@
+diff -aur ncbi-vdb-2.6.3.pristine/build/Makefile.install ncbi-vdb-2.6.3.new/build/Makefile.install
+--- ncbi-vdb-2.6.3.pristine/build/Makefile.install 2016-06-21 18:44:24.984945996 +0000
++++ ncbi-vdb-2.6.3.new/build/Makefile.install 2016-06-21 18:44:47.754945183 +0000
+@@ -66,11 +66,7 @@
+ PROFILE_FILE = $(ROOT)/etc/profile.d/ncbi-vdb
+ KONFIG_DIR = $(ROOT)/etc/ncbi/
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- endif
+-endif
++LINUX_ROOT = false
+
+ install: copylibs copyincludes
+ ifeq (true, $(LINUX_ROOT))