summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorapolih2016-01-29 16:49:10 -0600
committerapolih2016-01-29 16:49:10 -0600
commit8c66b3c0a86d2cbf2047ac8ed0b6033e9893d57a (patch)
tree3f44f856e75f33ce9f0df29bf15472a7715b267d
downloadaur-8c66b3c0a86d2cbf2047ac8ed0b6033e9893d57a.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
-rw-r--r--ncbi-vdb.patch31
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f6f030cf301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 22:49:02 UTC 2016
+pkgbase = ncbi-vdb
+ pkgdesc = The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives.
+ pkgver = 2.5.7
+ pkgrel = 1
+ url = https://github.com/ncbi/ncbi-vdb
+ arch = x86_64
+ license = custom:PublicDomain
+ depends = libxml2
+ depends = ngs
+ depends = hdf5
+ provides = ncbi-vdb
+ source = https://github.com/ncbi/ncbi-vdb/archive/2.5.7.tar.gz
+ source = ncbi-vdb.patch
+ sha256sums = e088717270a48f070d5aeb633558e778081c70e5c42e5e621d6a5b8f3c2c5e41
+ sha256sums = 19f09b19cad2ebd4df4185022e711f9bc32898926168d234833e56d70c2d2029
+
+pkgname = ncbi-vdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71eb250b9c54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is the PKGBUILD for ncbi-vdb
+# Maintainer: Aaron Baker <aa{last name}99{at}gmail{dt}org>
+
+pkgname=ncbi-vdb
+pkgver=2.5.7
+pkgrel=1
+pkgdesc="The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives."
+arch=('x86_64')
+url="https://github.com/ncbi/ncbi-vdb"
+depends=('libxml2' 'ngs' 'hdf5')
+provides=('ncbi-vdb')
+license=('custom:PublicDomain')
+source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz" "$pkgname.patch")
+sha256sums=('e088717270a48f070d5aeb633558e778081c70e5c42e5e621d6a5b8f3c2c5e41' '19f09b19cad2ebd4df4185022e711f9bc32898926168d234833e56d70c2d2029')
+
+prepare(){
+ cd "${pkgname}-${pkgver}"
+ # ncbi build process frequently checks if we are root user which interferes
+ # with makepkg use of fakeroot
+ patch -p1 -i "$srcdir/$pkgname.patch"
+}
+
+build(){
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix="$pkgdir/usr/"
+ make
+}
+
+check(){
+ cd "${pkgname}-${pkgver}"
+ make -k test
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ # ncbi does not use autoconf/automake so there is no respect for DESTDIR
+ # but there is a ROOT(dir)
+ make "ROOT=$pkgdir" install
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+
+ # the source of this package is required by others
+ # TODO is there somewhere to put this for namcap not to complain?
+ mkdir -p "$pkgdir/usr/src/${pkgname}-${pkgver}"
+ cp -r . "$pkgdir/usr/src/${pkgname}-${pkgver}"
+
+ # add the license
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ cp "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+
+ # TODO without this a link from libncbi-vdb-static.a -> libncbi-vdb.a is dead because
+ # libncbi-vdb.a gets removed somehow??
+ cd "$pkgdir/usr/lib/"
+ ln -sf libncbi-vdb.a.2.5.7 libncbi-vdb-static.a
+ ln -sf libncbi-wvdb.a.2.5.7 libncbi-wvdb-static.a
+}
diff --git a/ncbi-vdb.patch b/ncbi-vdb.patch
new file mode 100644
index 000000000000..eccbbc8890a0
--- /dev/null
+++ b/ncbi-vdb.patch
@@ -0,0 +1,31 @@
+diff -aur ncbi-vdb-2.5.7.pristine/build/Makefile.install ncbi-vdb-2.5.7.new/build/Makefile.install
+--- ncbi-vdb-2.5.7.pristine/build/Makefile.install 2016-01-26 21:10:12.713909719 +0000
++++ ncbi-vdb-2.5.7.new/build/Makefile.install 2016-01-26 21:18:28.630558667 +0000
+@@ -66,11 +66,7 @@
+ PROFILE_FILE = $(ROOT)/etc/profile.d/ncbi-vdb
+ KONFIG_DIR = $(ROOT)/etc/ncbi/
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- endif
+-endif
++LINUX_ROOT = false
+
+ install: copylibs copyincludes
+ ifeq (true, $(LINUX_ROOT))
+diff -aur ncbi-vdb-2.5.7.pristine/setup/install.perl ncbi-vdb-2.5.7.new/setup/install.perl
+--- ncbi-vdb-2.5.7.pristine/setup/install.perl 2016-01-26 21:10:12.810576379 +0000
++++ ncbi-vdb-2.5.7.new/setup/install.perl 2016-01-26 21:11:20.967240611 +0000
+@@ -81,11 +81,9 @@
+ prepare();
+
+ my $LINUX_ROOT;
+-++$LINUX_ROOT if (linux_root());
+ my $ROOT = '';
+ if ($OPT{root}) {
+ $ROOT = "$OPT{root}/root";
+- ++$LINUX_ROOT;
+ foreach ("$ROOT/usr/include", "$ROOT/etc/profile.d") {
+ unless (-e $_) {
+ print "mkdir -p $_... ";