summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwhoizit2021-12-21 01:51:32 +0300
committerwhoizit2021-12-21 01:51:32 +0300
commit171ba90247941da45c6f1c8e61e8700bad58682b (patch)
tree8e8a8a904f9e116f5c60dc5183b5ab050e346150
parent3d097ee82ab49a7f2321634cbfde6f11a9afe76c (diff)
downloadaur-171ba90247941da45c6f1c8e61e8700bad58682b.tar.gz
add patch for uit_dl.c from mainstream
-rw-r--r--PKGBUILD16
-rw-r--r--uit_dl.c.patch29
2 files changed, 41 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 508f53035d8c..5b5fc7a2514f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,22 @@
pkgname=ncdc
pkgver=1.22.1
-pkgrel=3
+pkgrel=4
pkgdesc='Modern and lightweight direct connect client with a friendly ncurses interface'
arch=('i686' 'x86_64' 'arm' 'armv6h')
url='http://dev.yorhel.nl/ncdc'
license=('MIT')
depends=('gnutls' 'sqlite' 'glib2' 'libmaxminddb')
-source=("http://dev.yorhel.nl/download/$pkgname-$pkgver.tar.gz"{,.asc})
+source=(
+ "http://dev.yorhel.nl/download/$pkgname-$pkgver.tar.gz"{,.asc}
+ uit_dl.c.patch
+)
validpgpkeys=('74460D32B80810EBA9AFA2E962394C698C2739FA') # Yoran Heling, only used for releases
+prepare() {
+ patch --directory="$pkgname-$pkgver" --forward --strip=1 --input="${srcdir}/uit_dl.c.patch"
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --with-geoip
@@ -27,5 +34,6 @@ package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-sha256sums=('d15fd378aa345f423e59a38691c668f69b516cd4b8afbbcdc446007740c3afad'
- 'SKIP')
+sha512sums=('b084ee28a799705009600c450016719ebb992cb0bf7e026513f4cd7e93b2566e7bf8e352eec92f3d69612ce06c930587759d7f7d20d14ee9fe1d5c4b8c4393af'
+ 'SKIP'
+ '8a4f10ecb9da5793fa4c705360b8a8e92206ac3b327507387bc4f22290bc2c77b4291f258d196d6bc63358324979b642e0ec579dff92405a5b209b2921b33f35')
diff --git a/uit_dl.c.patch b/uit_dl.c.patch
new file mode 100644
index 000000000000..e740150a5126
--- /dev/null
+++ b/uit_dl.c.patch
@@ -0,0 +1,29 @@
+From 4126dd51e90deb9e22dfd139cc4518a7812fcad6 Mon Sep 17 00:00:00 2001
+From: Yorhel <git@yorhel.nl>
+Date: Fri, 29 Oct 2021 14:29:45 +0200
+Subject: uit_dl.c: Use mvaddstr() instead of mvprintw() for dynamic string
+
+Trips up on Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=997167
+
+Not actually a bug in this case, the given string cannot contain printf
+formatting codes.
+---
+ src/uit_dl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/uit_dl.c b/src/uit_dl.c
+index 2012b49..dd75144 100644
+--- a/src/uit_dl.c
++++ b/src/uit_dl.c
+@@ -224,7 +224,7 @@ static void t_draw(ui_tab_t *tab) {
+ if(sel) {
+ char hash[40] = {};
+ base32_encode(sel->hash, hash);
+- mvprintw(bottom, 0, hash);
++ mvaddstr(bottom, 0, hash);
+ } else
+ mvaddstr(bottom, 0, "Nothing selected.");
+ mvprintw(bottom, wincols-19, "%5d files - %3d%%", g_hash_table_size(dl_queue), pos);
+--
+cgit v1.2.3
+