summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2021-04-25 01:40:51 -0400
committerredfish2021-04-25 01:40:51 -0400
commit6e047ed64450f2c2aa705ed7a46d8e4104506f24 (patch)
tree5d43a1a261f059b0a24dad83560e45f4eb8aba06
parentc83183775b3983d77ccb97199f8260c340d83c34 (diff)
downloadaur-6e047ed64450f2c2aa705ed7a46d8e4104506f24.tar.gz
0.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD50
2 files changed, 39 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d159aa44096a..33ec5b46937d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncdns
pkgdesc = Namecoin to DNS bridge daemon
- pkgver = 0.0.10.3
+ pkgver = 0.1.2
pkgrel = 1
url = https://github.com/namecoin/ncdns
install = ncdns.install
@@ -11,9 +11,11 @@ pkgbase = ncdns
depends = libcap
optdepends = namecoin-core: the Namecoin node
backup = etc/ncdns.conf
- source = ncdns-0.0.10.3.tar.gz::https://github.com/namecoin/ncdns/archive/v0.0.10.3.tar.gz
+ source = ncdns-0.1.2.tar.gz::https://github.com/namecoin/ncdns/archive/v0.1.2.tar.gz
+ source = x509-compressed-11c148e3a82a374dc8cc7800729ae31d1de3514b.tar.gz::https://github.com/namecoin/x509-compressed/archive/11c148e3a82a374dc8cc7800729ae31d1de3514b.tar.gz
source = ncdns.service
- sha512sums = 6e6d25989edbcdf963c0e4275fe164a0726c142a0acbf7fe3e74c2a18da7dcf2fbe8f0a3a5877ac7b551614ff227dd085490c9cfab6c8dce8e891badd87087a0
+ sha512sums = a7b95bdaeb781f49f6bc70e4d43f6a513b48d46f279a2c1993002cf20ef63330799e32a7442db37cda84590d57a352e3bd2642db1d863cb858bd8de7d7741177
+ sha512sums = 6a78e4777ea041ccfb7299322cc2bf6ab0db10ad7a28c6f8ec8293409fd4af1638e0c91618b465b6b4fbbaf25bc2b8f32af0e08191713afe420620a8534c5910
sha512sums = 4fca961ae7fc17fbb159dc6cfe3bf6be52b7e1423f0c04591100780a72f250cb87263e3eb736b363d2e67dbd8485018cbaa720ccaa4450bb93d220f802b4be40
pkgname = ncdns
diff --git a/PKGBUILD b/PKGBUILD
index e5a930627cc6..104fa24eab78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: redfish <redfish@galactica.pw>
pkgname=ncdns
-pkgver=0.0.10.3
+pkgver=0.1.2
pkgrel=1
+_x509_compressed_commit=11c148e3a82a374dc8cc7800729ae31d1de3514b
pkgdesc='Namecoin to DNS bridge daemon'
url='https://github.com/namecoin/ncdns'
@@ -16,36 +17,53 @@ install="ncdns.install"
backup=("etc/ncdns.conf")
source=($pkgname-$pkgver.tar.gz::https://github.com/namecoin/ncdns/archive/v${pkgver}.tar.gz
+ x509-compressed-${_x509_compressed_commit}.tar.gz::https://github.com/namecoin/x509-compressed/archive/${_x509_compressed_commit}.tar.gz
ncdns.service)
-prepare() {
- export GOPATH=$srcdir/$pkgname-$pkgver/_build
- go get -t -d github.com/namecoin/ncdns/...
-}
+_gopath=gopath
+_pkgpath=github.com/namecoin
-build() {
- cd $srcdir/$pkgname-$pkgver
+prepare() {
+ export GOPATH=$srcdir/${_gopath}
- export GOPATH=$srcdir/$pkgname-$pkgver/_build
+ mkdir -p "${_pkgpath}"
+ mv x509-compressed-${_x509_compressed_commit} ${_pkgpath}/x509-compressed
+ mv $pkgname-$pkgver ${_pkgpath}/$pkgname
- # make # fails due to generate step not being run for x509-signature-splice
+ pushd ${_pkgpath}/x509-compressed
+ go mod init ${_pkgpath}/x509-compressed
+ go mod tidy
+ go generate ./...
+ go mod tidy
+ popd
- pushd $GOPATH/src/github.com/namecoin/x509-signature-splice
- go generate github.com/namecoin/x509-signature-splice/...
+ pushd ${_pkgpath}/$pkgname
+ go mod init ${_pkgpath}/$pkgname
+ go mod tidy
+ go mod edit -replace ${_pkgpath}/x509-compressed=../x509-compressed
+ go mod tidy
popd
+}
+
+build() {
+ export GOPATH=$srcdir/${_gopath}
- go get -t github.com/namecoin/ncdns/...
+ cd ${_pkgpath}/$pkgname
+ go install ./...
}
package() {
- cd $srcdir/$pkgname-$pkgver
- export GOPATH=$srcdir/$pkgname-$pkgver/_build
+ export GOPATH=$srcdir/${_gopath}
+
+ cd ${_pkgpath}/$pkgname
+
install -Dm 755 $GOPATH/bin/ncdns "$pkgdir/usr/bin/ncdns"
- install -Dm 644 "$srcdir"/ncdns.service "$pkgdir/usr/lib/systemd/system/ncdns.service"
+ install -Dm 644 $srcdir/ncdns.service "$pkgdir/usr/lib/systemd/system/ncdns.service"
install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" README.md _doc/ncdns.conf.example
# we copy from template, but user must edit the conf file before starting service
install -Dm 644 _doc/ncdns.conf.example "$pkgdir/etc/ncdns.conf"
}
-sha512sums=('6e6d25989edbcdf963c0e4275fe164a0726c142a0acbf7fe3e74c2a18da7dcf2fbe8f0a3a5877ac7b551614ff227dd085490c9cfab6c8dce8e891badd87087a0'
+sha512sums=('a7b95bdaeb781f49f6bc70e4d43f6a513b48d46f279a2c1993002cf20ef63330799e32a7442db37cda84590d57a352e3bd2642db1d863cb858bd8de7d7741177'
+ '6a78e4777ea041ccfb7299322cc2bf6ab0db10ad7a28c6f8ec8293409fd4af1638e0c91618b465b6b4fbbaf25bc2b8f32af0e08191713afe420620a8534c5910'
'4fca961ae7fc17fbb159dc6cfe3bf6be52b7e1423f0c04591100780a72f250cb87263e3eb736b363d2e67dbd8485018cbaa720ccaa4450bb93d220f802b4be40')