summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2020-05-19 14:09:54 +0200
committerAngelo Theodorou2020-05-19 14:09:54 +0200
commit8993892d734b418a0ca008c10e720d79914a0da4 (patch)
tree929465ffc15c4acd7f74604b87d3104447529d43
parent54a3aed9595672fbd1e35953f83fd60ae39f9800 (diff)
downloadaur-8993892d734b418a0ca008c10e720d79914a0da4.tar.gz
Use the `develop` branch
- Disable compilation with GLEW - Move lua in the depends array
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9f858fe8c62..92927939e25b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncine-git
pkgdesc = A multi-platform 2D game engine
- pkgver = r247.a772675
+ pkgver = r309.627aa39
pkgrel = 1
url = http://ncine.github.io
arch = i686
@@ -13,13 +13,12 @@ pkgbase = ncine-git
depends = openal
depends = libvorbis
depends = libwebp
+ depends = lua
depends = hicolor-icon-theme
- optdepends = glew
- optdepends = lua
provides = ncine
conflicts = ncine
options = !strip
- source = git://github.com/nCine/nCine
+ source = git://github.com/nCine/nCine#branch=develop
md5sums = SKIP
pkgname = ncine-git
diff --git a/PKGBUILD b/PKGBUILD
index bec3a11cfc85..f22500130420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=ncine-git
-pkgver=r247.a772675
+pkgver=r309.627aa39
pkgrel=1
pkgdesc="A multi-platform 2D game engine"
arch=('i686' 'x86_64')
url="http://ncine.github.io"
license=('MIT')
-depends=('glfw' 'openal' 'libvorbis' 'libwebp' 'hicolor-icon-theme')
-optdepends=('glew' 'lua')
+depends=('glfw' 'openal' 'libvorbis' 'libwebp' 'lua' 'hicolor-icon-theme')
makedepends=('git' 'cmake' 'doxygen')
conflicts=('ncine')
provides=('ncine')
options=(!strip)
-source=('git://github.com/nCine/nCine')
+source=('git://github.com/nCine/nCine#branch=develop')
md5sums=('SKIP')
pkgver() {
@@ -32,6 +31,7 @@ build() {
mkdir -p build && cd build
cmake ../nCine\
+ -DNCINE_WITH_GLEW=OFF\
-DCMAKE_BUILD_TYPE=Release\
-DNCINE_BUILD_TESTS=ON\
-DNCINE_INSTALL_DEV_SUPPORT=ON\