summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2023-07-14 18:13:16 +0200
committerAngelo Theodorou2023-07-14 18:13:16 +0200
commitb5f31dea85507a4ffd2794afe6faccdc2ddcaad8 (patch)
treefa86915e783a836c630e2d1dcb3c9a2876f83b63
parent06b8c2a7a125d129df886e7eed00f9217889cf59 (diff)
downloadaur-b5f31dea85507a4ffd2794afe6faccdc2ddcaad8.tar.gz
Remove prepare pass and add repos to source array
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46e44232b211..54fda2c49ff9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,8 @@ pkgbase = ncinvaders-git
conflicts = ncinvaders
options = !strip
source = git+https://github.com/nCine/ncInvaders
+ source = git+https://github.com/nCine/ncInvaders-data
+ md5sums = SKIP
md5sums = SKIP
pkgname = ncinvaders-git
diff --git a/PKGBUILD b/PKGBUILD
index 622269e405a3..1645d167da80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,14 @@ makedepends=('git' 'cmake')
conflicts=('ncinvaders')
provides=('ncinvaders')
options=(!strip)
-source=('git+https://github.com/nCine/ncInvaders')
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/nCine/ncInvaders'
+ 'git+https://github.com/nCine/ncInvaders-data'
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd "$srcdir/ncInvaders"
@@ -23,10 +29,6 @@ pkgver() {
)
}
-prepare() {
- git clone https://github.com/nCine/ncInvaders-data || git -C ncInvaders-data pull
-}
-
build() {
mkdir -p build && cd build