summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsgelb2015-06-10 10:35:39 +0200
committersgelb2015-06-10 10:35:39 +0200
commit5d837184e717a3338eb79df8c7f60a44ab765f78 (patch)
treeec7c2b2c075a88900e6d47bcde4c2be9dae2cdbe
downloadaur-5d837184e717a3338eb79df8c7f60a44ab765f78.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD44
-rw-r--r--ncmpcpp-git.install11
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b4cc3e8724b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ncmpcpp-git
+ pkgdesc = An almost exact clone of ncmpc with some new features.
+ pkgver = 1891.746527f
+ pkgrel = 1
+ epoch = 1
+ url = http://unkart.ovh.org/ncmpcpp/
+ install = ncmpcpp-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = boost
+ makedepends = pkg-config
+ depends = ncurses
+ depends = libmpdclient>=2.8
+ depends = boost-libs
+ optdepends = curl: fetch lyrics
+ optdepends = taglib: tag editor
+ optdepends = fftw: frequency spectrum mode visualization
+ conflicts = ncmpcpp
+ conflicts = ncmpcpp-xdg-config
+ conflicts = ncmpcpp-xdg-config-git
+ conflicts = ncmpcpp-color
+ source = git+git://repo.or.cz/ncmpcpp.git
+ md5sums = SKIP
+
+pkgname = ncmpcpp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f34a96c51ab9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2c4ef5e0d7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: rich_o <rich_o@lavabit.com>
+# Maintainer: rich_o <rich_o@lavabit.com>
+
+_pkgname="ncmpcpp"
+pkgname="${_pkgname}-git"
+pkgver=1891.746527f
+pkgrel=1
+epoch=1
+pkgdesc="An almost exact clone of ncmpc with some new features."
+arch=('i686' 'x86_64')
+url="http://unkart.ovh.org/ncmpcpp/"
+license=('GPL2')
+depends=('ncurses' 'libmpdclient>=2.8' 'boost-libs')
+makedepends=('git' 'boost' 'pkg-config')
+optdepends=('curl: fetch lyrics'
+ 'taglib: tag editor'
+ 'fftw: frequency spectrum mode visualization'
+ )
+conflicts=('ncmpcpp' 'ncmpcpp-xdg-config' 'ncmpcpp-xdg-config-git' 'ncmpcpp-color')
+install=${pkgname}.install
+source=("git+git://repo.or.cz/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_pkgname}"
+ ./autogen.sh BOOST_LIB_SUFFIX='' \
+ --prefix=/usr \
+ --enable-clock \
+ --enable-outputs \
+ --enable-visualizer
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ # make PREFIX=/usr DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir/" install
+ # find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
+}
diff --git a/ncmpcpp-git.install b/ncmpcpp-git.install
new file mode 100644
index 000000000000..0ea0f71de72b
--- /dev/null
+++ b/ncmpcpp-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo ""
+ echo ":: Example configuration files can be found in"
+ echo ":: /usr/share/doc/ncmpcpp"
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: