summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2022-05-07 09:54:55 +0200
committerBlair Bonnett2022-05-07 09:54:55 +0200
commit0ab6109d0e4e5bd85a8c73d590b8078798b0b701 (patch)
tree44452450e302e2c36c14362033995e903784d432
parent37da6fae688ab7d683ca0667ab1617caf0d138e6 (diff)
downloadaur-0ab6109d0e4e5bd85a8c73d590b8078798b0b701.tar.gz
Update to 5.0.7.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--use_antlr2.patch10
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d0b13f0249..479bd109da5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nco
pkgdesc = netCDF Operators allow users to manipulate and analyse data stored in NetCDF files
- pkgver = 5.0.6
+ pkgver = 5.0.7
pkgrel = 1
url = http://nco.sourceforge.net/
arch = x86_64
@@ -9,8 +9,11 @@ pkgbase = nco
depends = netcdf
depends = udunits
depends = gsl
+ depends = curl
options = !libtool
- source = nco-5.0.6.tar.gz::https://github.com/nco/nco/archive/5.0.6.tar.gz
- sha256sums = d4c74e0268af94bdddcb0c77189830992f61c04147c23669b66470f1a8595d60
+ source = nco-5.0.7.tar.gz::https://github.com/nco/nco/archive/5.0.7.tar.gz
+ source = use_antlr2.patch
+ sha256sums = 6ddb397e7de4a7876e7d84ea82d4ee716cfd60ad8ee50ef49716945c505cbc1d
+ sha256sums = 242be592df0682ea06b6562cb313c97b7efa4fe56bbd5d700d833a8c14e88bc3
pkgname = nco
diff --git a/PKGBUILD b/PKGBUILD
index 77778d22ceb8..f8e1f4b334cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,29 @@
# Contributor: Graziano Giuliani <graziano.giuliani@gmail.com>
pkgname=nco
-pkgver=5.0.6
+pkgver=5.0.7
pkgrel=1
pkgdesc="netCDF Operators allow users to manipulate and analyse data stored in NetCDF files"
url="http://nco.sourceforge.net/"
license=("GPL")
-depends=('netcdf' 'udunits' 'gsl')
+depends=('netcdf' 'udunits' 'gsl' 'curl')
makedepends=('antlr2')
arch=('x86_64')
options=('!libtool')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/nco/nco/archive/$pkgver.tar.gz"
+ 'use_antlr2.patch'
)
sha256sums=(
- 'd4c74e0268af94bdddcb0c77189830992f61c04147c23669b66470f1a8595d60'
+ '6ddb397e7de4a7876e7d84ea82d4ee716cfd60ad8ee50ef49716945c505cbc1d'
+ '242be592df0682ea06b6562cb313c97b7efa4fe56bbd5d700d833a8c14e88bc3'
)
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 -i "$srcdir/use_antlr2.patch"
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr
diff --git a/use_antlr2.patch b/use_antlr2.patch
new file mode 100644
index 000000000000..9e042713b160
--- /dev/null
+++ b/use_antlr2.patch
@@ -0,0 +1,10 @@
+--- configure
++++ configure
+
+@@ -20465,5 +20465,5 @@
+ # AC_CHECK_PROGS (variable, progs-to-check-for, [value-if-not-found], [path]
+ # Check for antlr executable installed as runantlr (runantlr ~= java antlr.Tool)
+-for ac_prog in runantlr antlr
++for ac_prog in runantlr2 antlr
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.