summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:42:26 +0200
committergraziano.giuliani2015-07-04 16:42:26 +0200
commita31e3c9f08f20023c1642244707ef16b75fb868a (patch)
treeef2aa364fe02a92cb96cf385d928f6d034cb04b0
downloadaur-a31e3c9f08f20023c1642244707ef16b75fb868a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6c281031353
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nco
+ pkgdesc = netCDF Operators allow users to manipulate and analyse data stored in NetCDF files
+ pkgver = 4.4.8
+ pkgrel = 1
+ url = http://nco.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = antlr2
+ depends = netcdf
+ depends = udunits
+ depends = gsl
+ options = !libtool
+ source = http://nco.sourceforge.net/src/nco-4.4.8.tar.gz
+ md5sums = 842a118251da3875e7e2ab2cb0ec77fe
+
+pkgname = nco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7038a4b3848b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Graziano Giuliani <giuliani@lamma.rete.toscana.it>
+# Maintainer: Frank Schäffer <frank.schaeffer@o2online.de>
+pkgname=nco
+pkgver=4.4.8
+pkgrel=1
+pkgdesc="netCDF Operators allow users to manipulate and analyse data stored in NetCDF files"
+url="http://nco.sourceforge.net/"
+license="GPL"
+depends=('netcdf' 'udunits' 'gsl')
+makedepends=('antlr2')
+arch=('i686' 'x86_64')
+options=('!libtool')
+source=(http://nco.sourceforge.net/src/${pkgname}-${pkgver}.tar.gz)
+md5sums=('842a118251da3875e7e2ab2cb0ec77fe')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i configure -e 's/runantlr/runantlr2/g'
+ ./configure --prefix=/usr \
+ --enable-netcdf-4 \
+ --enable-gsl \
+ --enable-ncoxx \
+ --enable-udunits2 \
+ --enable-optimize-custom \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install install-html || return 1
+}
+# vim:set ts=4 sw=4 et: