summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2019-06-03 19:37:12 +0200
committerAngelo Theodorou2019-06-03 19:37:12 +0200
commit1f046f13fbf60d74cf0e3803bc16a4b8237f5878 (patch)
treeba5628bb820ebe637324bc1b30df0670d9c2a924
downloadaur-1f046f13fbf60d74cf0e3803bc16a4b8237f5878.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f8432611cfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ncparticleeditor-git
+ pkgdesc = A particle editor made with the nCine
+ pkgver = r28.44e7e7a
+ pkgrel = 1
+ url = http://ncine.github.io
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = ncine
+ provides = ncparticleeditor
+ conflicts = ncparticleeditor
+ options = !strip
+ source = git://github.com/nCine/ncParticleEditor
+ md5sums = SKIP
+
+pkgname = ncparticleeditor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..999b53ba4869
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Angelo Theodorou <encelo@gmail.com>
+
+pkgname=ncparticleeditor-git
+pkgver=r28.44e7e7a
+pkgrel=1
+pkgdesc="A particle editor made with the nCine"
+arch=('i686' 'x86_64')
+url="http://ncine.github.io"
+license=('MIT')
+depends=('ncine')
+makedepends=('git' 'cmake')
+conflicts=('ncparticleeditor')
+provides=('ncparticleeditor')
+options=(!strip)
+source=('git://github.com/nCine/ncParticleEditor')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ncParticleEditor"
+ ( set -o pipefail
+ git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ git clone https://github.com/nCine/ncParticleEditor-data || git -C ncParticleEditor-data pull
+}
+
+build() {
+ mkdir -p build && cd build
+
+ cmake ../ncParticleEditor\
+ -DCMAKE_BUILD_TYPE=Release\
+ -DPACKAGE_BUILD_ANDROID=OFF\
+ -DPACKAGE_STRIP_BINARIES=ON\
+ -DPACKAGE_DEFAULT_DATA_DIR=/usr/share/ncparticleeditor/data\
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ make -C build DESTDIR=$pkgdir PREFIX= install
+ install -Dm0644 $srcdir/ncParticleEditor/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}