summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2019-06-02 20:47:09 +0200
committerAngelo Theodorou2019-06-02 20:47:09 +0200
commit0402323aac60d8371da6cd2cd9581ff1854b59d0 (patch)
tree7758aca99830f33ef472bf5e84acb3d070f4f98d
downloadaur-0402323aac60d8371da6cd2cd9581ff1854b59d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20f3c5d491bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ncpong-git
+ pkgdesc = An example game made with the nCine
+ pkgver = r37.42a14b6
+ pkgrel = 1
+ url = http://ncine.github.io
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = ncine
+ provides = ncpong
+ conflicts = ncpong
+ options = !strip
+ source = git://github.com/nCine/ncPong
+ md5sums = SKIP
+
+pkgname = ncpong-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9598737d89d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Angelo Theodorou <encelo@gmail.com>
+
+pkgname=ncpong-git
+pkgver=r37.42a14b6
+pkgrel=1
+pkgdesc="An example game made with the nCine"
+arch=('i686' 'x86_64')
+url="http://ncine.github.io"
+license=('MIT')
+depends=('ncine')
+makedepends=('git' 'cmake')
+conflicts=('ncpong')
+provides=('ncpong')
+options=(!strip)
+source=('git://github.com/nCine/ncPong')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ncPong"
+ ( set -o pipefail
+ git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ git clone https://github.com/nCine/ncPong-data || git -C ncPong-data pull
+}
+
+build() {
+ mkdir -p build && cd build
+
+ cmake ../ncPong\
+ -DCMAKE_BUILD_TYPE=Release\
+ -DPACKAGE_BUILD_ANDROID=OFF\
+ -DPACKAGE_STRIP_BINARIES=ON\
+ -DPACKAGE_DEFAULT_DATA_DIR=/usr/share/ncpong/data\
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ make -C build DESTDIR=$pkgdir PREFIX= install
+ install -Dm0644 $srcdir/ncPong/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}