summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2021-07-14 00:58:38 +0200
committerAngelo Theodorou2021-07-14 00:58:38 +0200
commit612b81acd5fb7cfbd2cd1debaae285bd64576b62 (patch)
tree5f7c378e56cad290e795b4514573c90bb0e218e8
parent0402323aac60d8371da6cd2cd9581ff1854b59d0 (diff)
downloadaur-612b81acd5fb7cfbd2cd1debaae285bd64576b62.tar.gz
Update CMake variables for new template scripts
- Change git describe command for pkgver function
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20f3c5d491bf..28664853eca4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncpong-git
pkgdesc = An example game made with the nCine
- pkgver = r37.42a14b6
+ pkgver = r71.b798c6e
pkgrel = 1
url = http://ncine.github.io
arch = i686
@@ -16,4 +16,3 @@ pkgbase = ncpong-git
md5sums = SKIP
pkgname = ncpong-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a9598737d89d..4cd5e838c950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=ncpong-git
-pkgver=r37.42a14b6
+pkgver=r71.b798c6e
pkgrel=1
pkgdesc="An example game made with the nCine"
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/ncPong"
( set -o pipefail
- git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --tags --long --exact-match 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
@@ -32,9 +32,10 @@ build() {
cmake ../ncPong\
-DCMAKE_BUILD_TYPE=Release\
- -DPACKAGE_BUILD_ANDROID=OFF\
- -DPACKAGE_STRIP_BINARIES=ON\
- -DPACKAGE_DEFAULT_DATA_DIR=/usr/share/ncpong/data\
+ -DCMAKE_PREFIX_PATH=/usr/lib/cmake/nCine\
+ -DNCPROJECT_BUILD_ANDROID=OFF\
+ -DNCPROJECT_STRIP_BINARIES=ON\
+ -DNCPROJECT_DEFAULT_DATA_DIR=/usr/share/ncpong/data\
-DCMAKE_INSTALL_PREFIX=/usr
make
}