summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2021-03-17 13:31:28 +0100
committerPeter Hofmann2021-03-17 13:31:28 +0100
commit4786c6bd441a3892e03e5316c10827d7be2d75b9 (patch)
tree698f35cfc55be2311e1118fe896cd12dfad375c2
parent3bbbb32360b17f76174871d8ddde86381332ead7 (diff)
downloadaur-4786c6bd441a3892e03e5316c10827d7be2d75b9.tar.gz
Revert "Add blunt workaround for building with GCC 10"
This reverts commit 8e57546ba0b0d0ac94505b840b089a15bd657f92. Upstream handles this now.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--fcommon.patch13
3 files changed, 4 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5c09da91eb5..b22552cc0e19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ncsa-mosaic-git
pkgdesc = One of the first graphical web browsers
pkgver = 2.7b6.r25.af942b9
- pkgrel = 3
+ pkgrel = 2
epoch = 1
url = https://github.com/yotann/ncsa-mosaic
arch = i686
@@ -22,9 +22,7 @@ pkgbase = ncsa-mosaic-git
conflicts = mosaic
options = !makeflags
source = git+https://github.com/yotann/ncsa-mosaic.git
- source = fcommon.patch
sha256sums = SKIP
- sha256sums = a228a1cd0f0a30362b198c53fb2d54264e9aff9932544dd6ace7fb0607bfbc29
pkgname = ncsa-mosaic-git
diff --git a/PKGBUILD b/PKGBUILD
index 2c0d1c86aadc..546fb1d5772e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=ncsa-mosaic-git
epoch=1
pkgver=2.7b6.r25.af942b9
_pkgver=2.7b6
-pkgrel=3
+pkgrel=2
pkgdesc="One of the first graphical web browsers"
url="https://github.com/yotann/ncsa-mosaic"
license=('custom')
@@ -19,20 +19,14 @@ makedepends=('git')
provides=("${pkgname%-git}" 'mosaic')
conflicts=("${pkgname%-git}" 'mosaic')
options=(!makeflags)
-source=('git+https://github.com/yotann/ncsa-mosaic.git' fcommon.patch)
-sha256sums=('SKIP'
- 'a228a1cd0f0a30362b198c53fb2d54264e9aff9932544dd6ace7fb0607bfbc29')
+source=('git+https://github.com/yotann/ncsa-mosaic.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "$_pkgver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 <"$srcdir"/fcommon.patch
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
make linux
diff --git a/fcommon.patch b/fcommon.patch
deleted file mode 100644
index e937b7875b14..000000000000
--- a/fcommon.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/makefiles/Makefile.linux b/makefiles/Makefile.linux
-index 2cea009..ad03902 100755
---- a/makefiles/Makefile.linux
-+++ b/makefiles/Makefile.linux
-@@ -225,7 +225,7 @@ customflags =
-
- # ---------------------- END OF CUSTOMIZABLE OPTIONS -------------------------
-
--CFLAGS = -g $(sysconfigflags) $(prereleaseflags)
-+CFLAGS = -fcommon -g $(sysconfigflags) $(prereleaseflags)
-
- # Don't worry about these -- for development purposes only.
- PURIFY = purify