summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2020-09-15 20:10:05 +0200
committerPeter Hofmann2020-09-15 20:10:05 +0200
commit8e57546ba0b0d0ac94505b840b089a15bd657f92 (patch)
tree454aeaea31c67d9b65dfc241efb7bb30fbf7c655
parent231f0c3ae307270d7bf5ced59008af05b44d76dd (diff)
downloadaur-8e57546ba0b0d0ac94505b840b089a15bd657f92.tar.gz
Add blunt workaround for building with GCC 10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--fcommon.patch13
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b22552cc0e19..a5c09da91eb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ncsa-mosaic-git
pkgdesc = One of the first graphical web browsers
pkgver = 2.7b6.r25.af942b9
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/yotann/ncsa-mosaic
arch = i686
@@ -22,7 +22,9 @@ pkgbase = ncsa-mosaic-git
conflicts = mosaic
options = !makeflags
source = git+https://github.com/yotann/ncsa-mosaic.git
+ source = fcommon.patch
sha256sums = SKIP
+ sha256sums = a228a1cd0f0a30362b198c53fb2d54264e9aff9932544dd6ace7fb0607bfbc29
pkgname = ncsa-mosaic-git
diff --git a/PKGBUILD b/PKGBUILD
index 999071c2e30b..85bc5a71d533 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=ncsa-mosaic-git
epoch=1
pkgver=2.7b6.r25.af942b9
_pkgver=2.7b6
-pkgrel=2
+pkgrel=3
pkgdesc="One of the first graphical web browsers"
url="https://github.com/yotann/ncsa-mosaic"
license=('custom')
@@ -19,14 +19,20 @@ makedepends=('git')
provides=("${pkgname%-git}" 'mosaic')
conflicts=("${pkgname%-git}" 'mosaic')
options=(!makeflags)
-source=('git+https://github.com/yotann/ncsa-mosaic.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/yotann/ncsa-mosaic.git' fcommon.patch)
+sha256sums=('SKIP'
+ 'a228a1cd0f0a30362b198c53fb2d54264e9aff9932544dd6ace7fb0607bfbc29')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "$_pkgver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 <"$srcdir"/fcommon.patch
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
make linux
diff --git a/fcommon.patch b/fcommon.patch
new file mode 100644
index 000000000000..e937b7875b14
--- /dev/null
+++ b/fcommon.patch
@@ -0,0 +1,13 @@
+diff --git a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+index 2cea009..ad03902 100755
+--- a/makefiles/Makefile.linux
++++ b/makefiles/Makefile.linux
+@@ -225,7 +225,7 @@ customflags =
+
+ # ---------------------- END OF CUSTOMIZABLE OPTIONS -------------------------
+
+-CFLAGS = -g $(sysconfigflags) $(prereleaseflags)
++CFLAGS = -fcommon -g $(sysconfigflags) $(prereleaseflags)
+
+ # Don't worry about these -- for development purposes only.
+ PURIFY = purify