summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGugy Lucky Khamdani2022-09-15 06:28:57 +0700
committerGugy Lucky Khamdani2022-09-15 06:28:57 +0700
commit0cb79ef5f6135474ea913396b32c5d10b0da2d2a (patch)
treecfd9e6963dd2c949c4e5471a9dd494edd9c41f80
parent94e98e78f964164049c7b8900b66ea10e937e4a6 (diff)
downloadaur-0cb79ef5f6135474ea913396b32c5d10b0da2d2a.tar.gz
Add desktop entry & notification icon hint
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93ce82552870..de91036ed743 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncspot-git
pkgdesc = Cross-platform ncurses Spotify client written in Rust, inspired by ncmpc and the likes.
- pkgver = 0.5.0
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/hrkfdn/ncspot
arch = x86_64
@@ -21,4 +21,3 @@ pkgbase = ncspot-git
sha512sums = SKIP
pkgname = ncspot-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 901438260e3c..77322d080183 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=ncspot
pkgname="${_pkgname}-git"
-pkgver=0.5.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="Cross-platform ncurses Spotify client written in Rust, inspired by ncmpc and the likes."
arch=('x86_64')
@@ -54,6 +54,8 @@ check() {
package() {
cd "${srcdir}/${_pkgname}"
install -Dm 755 "target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm 755 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm 644 "misc/ncspot.desktop" "${pkgdir}/usr/share/applications/ncspot.desktop"
+ install -Dm 644 "images/logo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/ncspot.svg"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}