summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-03-12 19:47:32 +0100
committerJulien Nicoulaud2019-03-12 19:47:32 +0100
commit0e086cb3a259f5181d3b3917ee90edc3913c9bd3 (patch)
treebd73d3279c58954be0624375d994c7d1888f9342
downloadaur-0e086cb3a259f5181d3b3917ee90edc3913c9bd3.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29d19ab04930
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ncspot-git
+ pkgdesc = Cross-platform ncurses Spotify client written in Rust, inspired by ncmpc and the likes.
+ pkgver = e507364
+ pkgrel = 1
+ url = https://github.com/hrkfdn/ncspot
+ arch = x86_64
+ license = unknown
+ makedepends = rust
+ makedepends = cargo
+ depends = ncurses
+ depends = openssl
+ optdepends = libpulse: PulseAudio backend
+ optdepends = portaudio: PortAUdio backend
+ provides = ncspot
+ conflicts = ncspot
+ source = git+https://github.com/hrkfdn/ncspot.git
+ sha512sums = SKIP
+
+pkgname = ncspot-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ca31ce1f98f5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/ncspot/
+/pkg/
+/src/
+/*.tar.*
+/*.xz
+/*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98582a666be5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+
+_pkgname=ncspot
+pkgname="${_pkgname}-git"
+pkgver=e507364
+pkgrel=1
+pkgdesc="Cross-platform ncurses Spotify client written in Rust, inspired by ncmpc and the likes."
+arch=('x86_64')
+url="https://github.com/hrkfdn/ncspot"
+license=('unknown')
+depends=('ncurses' 'openssl')
+optdepends=('libpulse: PulseAudio backend'
+ 'portaudio: PortAUdio backend')
+makedepends=('rust' 'cargo')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/hrkfdn/ncspot.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags --always | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cargo build --release
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ cargo test --release
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm 755 "target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}