aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Blomstrand2018-10-17 21:26:26 +0200
committerMikael Blomstrand2018-10-17 21:26:26 +0200
commitd850bd687bc1094b0cbab0f95750b82270c0ff73 (patch)
tree0be3f6b96e0ad0932bf70aefc43c6b3fe2665a64
parent45e39358edbc5264d1dfa61a532c609e838ad747 (diff)
downloadaur-d850bd687bc1094b0cbab0f95750b82270c0ff73.tar.gz
Option to install only modified infocmp.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
-rw-r--r--README.md19
3 files changed, 49 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c1e1c78912e..1b83ace3a5bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,16 +17,27 @@ pkgbase = ncurses-nohex
source = https://ftp.gnu.org/pub/gnu/ncurses/ncurses-6.1.tar.gz
source = https://ftp.gnu.org/pub/gnu/ncurses/ncurses-6.1.tar.gz.sig
source = nohex.patch::https://github.com/mbloms/ncurses/commit/2e8af507b9ea61ca9f70e023e89faa16aa01c8b1.patch
+ source = README.md
validpgpkeys = C52048C0C0748FEE227D47A2702353E0F7E48EDB
md5sums = 98c889aaf8d23910d2b92d65be2e737a
md5sums = SKIP
md5sums = ba2cd274835935bf83bf3859a131fd1e
+ md5sums = 0fd492d6811b9f520fdfd6188f290069
sha1sums = 57acf6bc24cacd651d82541929f726f4def780cc
sha1sums = SKIP
sha1sums = 5fb4b04bd1c2c3ce89f140fffa6769dfd2e3f741
+ sha1sums = 0abec6eae58208ad167753fee41c63b130c16f0d
sha256sums = aa057eeeb4a14d470101eff4597d5833dcef5965331be3528c08d99cebaa0d17
sha256sums = SKIP
sha256sums = c59a4209ea84a31bba0ea5721ce1ed32252a951270dda3f932cfc6ab4ca821b8
+ sha256sums = 77aaa2c490d561955c1e28ab7fe32976553771e6bfe1ce0ffc57848ce4edb605
pkgname = ncurses-nohex
+pkgname = infocmp-nohex
+ pkgdesc = =infocmp patched to not use hexadecimal when they are "close" to a power of two.
+ depends = glibc
+ depends = libncursesw.so=6
+ provides = infocmp
+ conflicts =
+
diff --git a/PKGBUILD b/PKGBUILD
index d18ec3f27ba6..6d9bfa18f2bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
-pkgname=ncurses-nohex
+pkgname=('ncurses-nohex' 'infocmp-nohex')
conflicts=(ncurses)
pkgver=6.1
pkgrel=2
@@ -16,16 +16,20 @@ license=(MIT)
depends=(glibc gcc-libs)
provides=(ncurses libncurses++w.so libformw.so libmenuw.so libpanelw.so libncursesw.so)
source=(https://ftp.gnu.org/pub/gnu/ncurses/ncurses-$pkgver.tar.gz{,.sig}
- nohex.patch::https://github.com/mbloms/ncurses/commit/2e8af507b9ea61ca9f70e023e89faa16aa01c8b1.patch)
+ nohex.patch::https://github.com/mbloms/ncurses/commit/2e8af507b9ea61ca9f70e023e89faa16aa01c8b1.patch
+ README.md)
md5sums=('98c889aaf8d23910d2b92d65be2e737a'
'SKIP'
- 'ba2cd274835935bf83bf3859a131fd1e')
+ 'ba2cd274835935bf83bf3859a131fd1e'
+ '0fd492d6811b9f520fdfd6188f290069')
sha1sums=('57acf6bc24cacd651d82541929f726f4def780cc'
'SKIP'
- '5fb4b04bd1c2c3ce89f140fffa6769dfd2e3f741')
+ '5fb4b04bd1c2c3ce89f140fffa6769dfd2e3f741'
+ '0abec6eae58208ad167753fee41c63b130c16f0d')
sha256sums=('aa057eeeb4a14d470101eff4597d5833dcef5965331be3528c08d99cebaa0d17'
'SKIP'
- 'c59a4209ea84a31bba0ea5721ce1ed32252a951270dda3f932cfc6ab4ca821b8')
+ 'c59a4209ea84a31bba0ea5721ce1ed32252a951270dda3f932cfc6ab4ca821b8'
+ '77aaa2c490d561955c1e28ab7fe32976553771e6bfe1ce0ffc57848ce4edb605')
validpgpkeys=('C52048C0C0748FEE227D47A2702353E0F7E48EDB') # Thomas Dickey
@@ -44,7 +48,7 @@ build() {
make
}
-package() {
+package_ncurses-nohex() {
cd $conflicts-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -64,3 +68,12 @@ package() {
echo 'INPUT(-lncursesw)' > "$pkgdir/usr/lib/libcursesw.so"
ln -s libncurses.so "$pkgdir/usr/lib/libcurses.so"
}
+
+package_infocmp-nohex() {
+ pkgdesc=='infocmp patched to not use hexadecimal when they are "close" to a power of two.'
+ depends=('glibc' 'libncursesw.so=6')
+ conflicts=()
+ provides=('infocmp')
+
+ install -Dm755 ncurses-${pkgver}/progs/infocmp ${pkgdir}/usr/local/bin/infocmp
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e80482fa0672
--- /dev/null
+++ b/README.md
@@ -0,0 +1,19 @@
+# Why
+
+Since [`ncurses` 6.1](https://www.gnu.org/software/ncurses/#h3-programs)
+
+`tic` and `infocmp` display numeric values in hexadecimal when they are "close"
+to a power of two, "making the result more readable". This causes issues for
+`sbt` and and other programs using `jline < 2.14.4`. This package aims to
+provide a fix for that.
+
+## ncurses-nohex
+
+The `ncurses-nohex` package applies a patch that undo this functionality. The
+package replaces ncurses in full.
+
+## infocmp-nohex
+
+`infocmp-nohex` works with any build of ncurses by installing the `infocmp`
+binary to /usr/local/bin, effectively shadowing the normal infocmp. It's a bit
+of a hack but it works. \ No newline at end of file