summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2015-06-25 15:38:09 +0200
committerFederico Di Pierro2015-06-25 15:38:09 +0200
commit313244190d0b886b1949d1dc40721a6df6382924 (patch)
tree28339acb5df3ce67a4360f732beade1d28d1f9a2
parent9877575ab635d91606a3824ee4d49c786c231e08 (diff)
downloadaur-313244190d0b886b1949d1dc40721a6df6382924.tar.gz
Update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dcd53dd3335..728554e40228 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncursesfm-git
pkgdesc = A FileManager written in c and ncurses library.
- pkgver = 0.r181.d4004da
+ pkgver = 0.r209.f9dd23d
pkgrel = 1
url = https://github.com/FedeDP/ncursesFM
install = ncursesFM.install
@@ -8,16 +8,13 @@ pkgbase = ncursesfm-git
arch = x86_64
license = GPL
makedepends = git
- makedepends = libcups
- makedepends = openssl
- makedepends = libx11
depends = ncurses
depends = libconfig
depends = libarchive
- optdepends = libcups: for printing support
+ depends = libcups
+ depends = openssl
+ depends = libx11
optdepends = fuseiso: for fuse archive/iso mounting support
- optdepends = openssl: for shasum viewing support
- optdepends = libx11: used to check if program is started in a X screen
optdepends = xdg-utils: xdg-open support
backup = etc/default/ncursesFM.conf
source = git://github.com/FedeDP/ncursesFM.git
diff --git a/PKGBUILD b/PKGBUILD
index 63f6e27d72d4..62eb4c8b3da0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=ncursesfm-git
_gitname=ncursesFM
-pkgver=0.r181.d4004da
+pkgver=0.r209.f9dd23d
pkgrel=1
pkgdesc="A FileManager written in c and ncurses library."
arch=('i686' 'x86_64')
url="https://github.com/FedeDP/${_gitname}"
license=('GPL')
-depends=('ncurses' 'libconfig' 'libarchive')
-optdepends=('libcups: for printing support'
- 'fuseiso: for fuse archive/iso mounting support'
- 'openssl: for shasum viewing support'
- 'libx11: used to check if program is started in a X screen'
+depends=('ncurses' 'libconfig' 'libarchive' 'libcups' 'openssl' 'libx11')
+optdepends=('fuseiso: for fuse archive/iso mounting support'
'xdg-utils: xdg-open support')
-makedepends=('git' 'libcups' 'openssl' 'libx11')
+#depends=('git') -> libcups, openssl and libx11 are optional build dep.
+# If compiled without them, the program will run just fine;
+# but that would disable xdg-open, sha/md5sum and printing support.
+makedepends=('git')
source=("git://github.com/FedeDP/${_gitname}.git")
backup=('etc/default/ncursesFM.conf')
install=ncursesFM.install
@@ -34,8 +34,5 @@ build()
package() {
cd $srcdir/$_gitname
- mkdir -p $pkgdir/usr/bin
- install -Dm755 ncursesFM $pkgdir/usr/bin
- mkdir -p $pkgdir/etc/default
- install -Dm644 ncursesFM.conf $pkgdir/etc/default
+ make DESTDIR="$pkgdir" install
}