summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Garillot2017-10-11 16:23:14 -0700
committerFrançois Garillot2017-10-11 22:38:18 -0700
commitb553a9f7099f6688e38d691d223d87ca9746acfd (patch)
treef69a0fd423c6cf4f5674d6ac0b979cc8923375b2
downloadaur-b553a9f7099f6688e38d691d223d87ca9746acfd.tar.gz
First verison of ND4J package
Uses an uber-build.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64204b2a019d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Oct 12 05:38:12 UTC 2017
+pkgbase = nd4j-git
+ pkgdesc = ND4J is a Java library for accelerated linear algebra on n-dimensional Java arrays
+ pkgver = 20171011
+ pkgrel = 1
+ url = https://github.com/deeplearning4j/nd4j
+ arch = i686
+ arch = x86_64
+ license = Apache 2.0
+ makedepends = git
+ depends = libnd4j-git
+ depends = java-environment>=6.0
+ depends = java-environment<9
+ depends = maven>=3.3
+ optdepends = cuda>=8.0: cuda support
+ provides = nd4j
+ conflicts = nd4j
+ source = nd4j::git+https://github.com/deeplearning4j/nd4j.git
+ md5sums = SKIP
+
+pkgname = nd4j-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32796b0219bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: François Garillot <francois[@]garillot.net>
+
+pkgname=nd4j-git
+pkgver=20171011
+pkgrel=1
+pkgdesc="ND4J is a Java library for accelerated linear algebra on n-dimensional Java arrays"
+license=('Apache 2.0')
+url='https://github.com/deeplearning4j/nd4j'
+arch=('i686' 'x86_64')
+provides=('nd4j')
+conflicts=('nd4j')
+depends=('libnd4j-git' 'java-environment>=6.0' 'java-environment<9' 'maven>=3.3')
+optdepends=('cuda>=8.0: cuda support')
+makedepends=('git')
+options=()
+source=(${pkgname%-git}::git+https://github.com/deeplearning4j/nd4j.git)
+md5sums=('SKIP')
+
+build() {
+ cd ${pkgname%-git}
+ # set LIBND4J_HOME
+ source /etc/profile.d/libnd4j.sh
+ if (false && [ -f $LIBND4J_HOME/blasbuild/cuda/blas/libnd4jcuda\.so ]); then
+ _nd4jopts="-DskipTests=true -Pcuda"
+ else
+ _nd4jopts="-DskipTests=true -Pnative -pl !nd4j-backends/nd4j-backend-impls/nd4j-cuda,!nd4j-backends/nd4j-backend-impls/nd4j-cuda-platform,!nd4j-backends/nd4j-tests"
+ fi
+ export LIBND4J_HOME=$LIBND4J_HOME
+ mvn -e -X -q clean package -Puberjar $_nd4jopts
+}
+
+
+package() {
+ cd ${pkgname%-git}
+ install -dm755 "$pkgdir/usr/share/java/${pkgname%-git}"
+ for file in nd4j-uberjar/target/nd4j-uberjar*; do
+ install -Dm755 "$file" "$pkgdir/usr/share/java/${pkgname%-git}/"
+ done
+}