summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2022-01-05 19:33:33 +0100
committerGuilhem Saurel2022-01-05 19:33:33 +0100
commit2ea19426ed56f516a6ccaf100ede5a7bfe38b27f (patch)
tree28226462a75ace70eac37f4b246ddc9c287ea7e3
downloadaur-2ea19426ed56f516a6ccaf100ede5a7bfe38b27f.tar.gz
v1.1.0
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5676e3293e55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ndcurves
+ pkgdesc = Library for creating smooth cubic splines
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/loco-3d/ndcurves
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = eigen
+ depends = hpp-fcl
+ depends = eigenpy
+ depends = pinocchio
+ optdepends = doxygen
+ source = https://github.com/loco-3d/ndcurves/releases/download/v1.1.0/ndcurves-1.1.0.tar.gz
+ source = https://github.com/loco-3d/ndcurves/releases/download/v1.1.0/ndcurves-1.1.0.tar.gz.sig
+ validpgpkeys = 9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ndcurves
+
+pkgname = ndcurves-docs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b0ff163448d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+ndcurves*
+*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27eeccbb8440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guilhem Saurel <saurel@laas.fr>
+
+pkgorg='loco-3d'
+_pkgname='ndcurves'
+pkgname=("$_pkgname" "$_pkgname-docs")
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Library for creating smooth cubic splines"
+arch=('i686' 'x86_64')
+url="https://github.com/$pkgorg/$pkgname"
+license=('BSD')
+depends=('hpp-fcl' 'eigenpy' 'pinocchio')
+optdepends=('doxygen')
+makedepends=('cmake' 'eigen')
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"{,.sig})
+sha256sums=('SKIP' 'SKIP')
+validpgpkeys=('9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28')
+
+build() {
+ cd "$pkgbase-$pkgver"
+ cmake -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+check() {
+ cd "$pkgbase-$pkgver"
+ cmake --build build -t test
+}
+
+package_ndcurves() {
+ cd "$pkgbase-$pkgver"
+ export DESTDIR="$pkgdir/"
+ cmake --build build -t install
+ rm -rf "$pkgdir/usr/share/doc"
+}
+
+package_ndcurves-docs() {
+ cd "$pkgbase-$pkgver"
+ export DESTDIR="$pkgdir/"
+ cmake --build build -t install
+ rm -rf "$pkgdir"/usr/{lib,include,bin,"share/$_pkgname"}
+}