summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2024-08-17 14:51:16 +0200
committerAlexandre Bouvier2024-08-17 14:51:16 +0200
commit5e36629f1a50ba4f6c165c7ce53b0d7bdfed0a4b (patch)
tree6beacfa956734877a7088ef9d5c5bcc733a6eb0a
parentb6a770fe5f2dd5a4763d32669ed284be1366c373 (diff)
downloadaur-5e36629f1a50ba4f6c165c7ce53b0d7bdfed0a4b.tar.gz
update to 0.2.5.r20.g450f6fb
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1583b6bd237..251379693c49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = ndecrypt-git
pkgdesc = DS/3DS Encryption Tool
- pkgver = 0.2.5.r1.g71199ee
- pkgrel = 3
+ pkgver = 0.2.5.r20.g450f6fb
+ pkgrel = 1
url = https://github.com/SabreTools/NDecrypt
arch = x86_64
license = MIT
- makedepends = dotnet-sdk>=6
+ makedepends = dotnet-sdk>=8
makedepends = git
- depends = dotnet-runtime-6.0
+ depends = dotnet-runtime-8.0
depends = gcc-libs
depends = glibc
- provides = ndecrypt=0.2.5.r1.g71199ee
+ provides = ndecrypt=0.2.5.r20.g450f6fb
conflicts = ndecrypt
source = ndecrypt::git+https://github.com/SabreTools/NDecrypt.git
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 41df7724f578..fca8617b982d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=ndecrypt
pkgname=$_pkgname-git
-pkgver=0.2.5.r1.g71199ee
-pkgrel=3
+pkgver=0.2.5.r20.g450f6fb
+pkgrel=1
pkgdesc="DS/3DS Encryption Tool"
arch=('x86_64')
url="https://github.com/SabreTools/NDecrypt"
license=('MIT')
-depends=('dotnet-runtime-6.0' 'gcc-libs' 'glibc')
-makedepends=('dotnet-sdk>=6' 'git')
+depends=('dotnet-runtime-8.0' 'gcc-libs' 'glibc')
+makedepends=('dotnet-sdk>=8' 'git')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("$_pkgname::git+$url.git")
@@ -16,11 +16,7 @@ b2sums=('SKIP')
pkgver() {
cd $_pkgname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- sed -i 's/\(NDecrypt\)\.exe/\1/' $_pkgname/NDecrypt/Program.cs
+ git describe --long --tags --exclude=rolling | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -28,7 +24,7 @@ build() {
export DOTNET_NOLOGO=true
dotnet publish $_pkgname/NDecrypt \
--configuration Release \
- --framework net6.0 \
+ --framework net8.0 \
--output build \
--runtime linux-x64 \
--self-contained false